High Memory (Peak: ~ 1GB) and CPU Usage

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
critical
VERIFIED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: fedorsinev, Unassigned)

Tracking

({flashplayer, hang})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-09-10)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090616 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090616 Firefox/3.5

Very high memory, normally 150mb, now it's at least 300mb-1GB maximum. Abnormally high CPU usage, causes lagging in typing and flash applications. This happens in particular after watching flash videos with enabled hardware rendering. I had a lot of tabs open, but firefox used to maintain a 150-200MB memory use mark. I assume that the flash task/thread/ or application isn't removed from memory. My memory is rising at the moment. 670MB's at the moment, with 8%-30% of cpu usage on a Core 2 Duo. When I restart, it usually functions normally again.

If high enough memory takes place, firefox runs out of resources to store images, and sometimes crashes when memory is bad.

Reproducible: Always

Steps to Reproduce:
1. Work with any flash application/ or watch a video (preferably in hardware rendering which is what I tested.

2. Stop watching/ or close the tabs.

3. High CPU Usage and memory takes place.
Actual Results:  
High CPU Usage and memory takes place.

Expected Results:  
While watching the flash video, high CPU usage is expected, partly due to the fact of hardware rendering. But memory should have not gotten higher than 300MB's. When the flash application was terminated, it should have stopped using resources.

Intel Core 2 Duo T8100 @ 2.1ghz with 2 physical CPU's
4094MB's of R.A.M @ DDR2 800 mhz.
Nvidia Geforce 8800GTS.
Microsoft Longhorn Visa.

Number of actual crashes from memory loss: 2.
(Reporter)

Updated

8 years ago
Keywords: flashplayer, footprint, hang, topmlk
Version: unspecified → 3.5 Branch
Can you exclude leaking extensions by retesting Firefox in its safe-mode?
http://support.mozilla.com/en-US/kb/Safe+Mode
FYI: firefox.exe, running here since about 10 hours, is using 159.108 kB.
Version: 3.5 Branch → unspecified

Comment 2

8 years ago
flash v10?
Whiteboard: closeme 2009-09-10

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Keywords: footprint, topmlk

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.