Closed Bug 500147 Opened 12 years ago Closed 12 years ago

Pressing Enter in thread pane while root of a thread selected causes the thread expanded/collapsed state to toggle

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: rain1, Unassigned)

References

Details

(Keywords: regression)

An example of this bug causing problems is:
STR:
1. Run with the patch from bug 467768.
2. Make sure that on double-click/Enter, messages are opened in a new tab.
3. Switch to threaded mode.
4. Expand a thread and and select its root.
5. Press Enter. (double-click doesn't cause this bug, only enter does)

The summary's displayed instead of the message.

This happens because <http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/content/widgets/tree.xml#699> toggles the state from expanded to collapsed after we're done with the event handling.

Two potential workarounds:
1. Do a toggle ourselves, so that the two toggles cancel each other out.
2. (suggested by smaug on #developers) -- add a capturing listener to the tree's parent, and stop propagation there.

ccing Magnus and philor for ideas.
Flags: wanted-thunderbird3+
Severity: normal → minor
Keywords: regression
I can't reproduce this anymore.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
I don't see it either, when set to "open in new tab".  "open in new window" however expands the thread
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.