Can't 'Save Image As" and 'Browse' broken - both do nothing

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Peteroid, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

If I right-click on an image it brings up the sub-menu with the 'Save Image As...' option. If I click on this the screen 'blinks' (as if all icons momentarily disappear and reappear), the hour-glass comes up for about 10 seconds, and then nothing happens. If I go to 'Options:General:Download Files to Directory' and hit the 'Browse' button nothing happens. If in the 'File' Menu I choose 'Open File..' nothing happens. All seems to suggest it can't open the 'file browser'.

Reproducible: Always

Steps to Reproduce:
1. Find image on a web page.
2. Right-Click on image, opens 'Save Image As...' menu
3. Choose 'Save Image As...' (hour-glass icon for mouse)
4. nothing happens

1. Open Options : General : Directory to Download Files : Browse...
2. Hit Browse... button
3. Nothing happens

1. Open 'File' menu at top
2. Select 'Open File...'
3. nothing happens
Actual Results:  
nothing happens, so I can't save images, or change the download location directory, or open a file (these are the things I'm aware of).

Expected Results:  
I expected the "Save File As' to open the 'Save File' dialog box 
I expected the 'Browse' to open the file navigator dialog box
I expected the 'Open File' to open the file navigator dialog box


I just laded Mozilla for the first time last night. Everything else seems to work. It did at one point have a problem installing the Flash plug-in. The installation went fine. But it at first wouldn't let me just run from web site, it provided an 'manual install' button but it did nothing. Then when it put it in download manager attempting to open it warned me it was an 'exe' type, but then said I had to provide an application to open the 'exe' (???). I was able to install plug-in by just executing the exe on my system manually with Mozilla closed. It WILL allow me to 'Copy Image', as I'm able to then save using Photoshop (a hassle). Finally, I'm wondering it is because I use a TWO SCREEN system on a portable with an external monitor. The screen size might 'fool' it somehow (just speculating).
Could very well be caused by an add-on; please try safe-mode: http://support.mozilla.com/en-US/kb/Safe+Mode
Another option could be to clear your downloads list, or to delete files like downloads.sqlite and mimeTypes.rdf in your profile folder:
http://support.mozilla.com/en-US/kb/Profiles
Version: unspecified → 3.0 Branch
Works for me. Please visit the support site (http://support.mozilla.com) for further assistance - start with the articles Ria mentioned, if that doesn't help try forums or live chat for personalized support - if it really does turn out to be a bug they can help you file a report that will be useful to our developers in resolving the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.