Closed Bug 500197 Opened 12 years ago Closed 11 years ago

Password dialog does not identify which calendar you are logging into.

Categories

(Calendar :: Provider: CalDAV, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 247486

People

(Reporter: IDontUseMozillaAnyMore, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090616 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090624 Calendar/1.0pre

If you have more than one diary account on the same server it is impossible to know which you are being asked to login to. The password dialog needs to specify which calendar it is asking you for the user name and password for.

Reproducible: Always

Steps to Reproduce:
1. Setup Sunbird with two different diaries with different usernames on the same server.
2. Quit sunbird without saving the passwords.
3. Start sunbird.
Actual Results:  
You will be asked for the username and password details for a diary but you will not know which diary you are meant to login to.

Expected Results:  
The system should at least give you a fighting chance of getting the username and password correct by specifying which calendar you are logging into.
OS: Mac OS X → All
Hardware: x86 → All
Summary: Password dialog does not identify which diary you are logging into. → Password dialog does not identify which calendar you are logging into.
Loging to a "Calendar" is not supported, you are loging to a "hostname" and a "realm" so typically, if you have more than one calendar on the same host the same credentials will be used. 

I would mark this as duplicate of bug 247486
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 247486
You need to log in before you can comment on or make changes to this bug.