Typing space in any text input crashes Mozilla

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
P3
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Jeffrey Baker, Assigned: rods (gone))

Tracking

({crash, regression, top100})

Trunk
x86
Linux
crash, regression, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+], URL)

(Reporter)

Description

18 years ago
Linux 2000-08-23-11.  Whenever I type a space in any text input, Mozilla
crashes.  This is easily reproduced on http://www.google.com
http://bugzilla.mozilla.org, and generally anywhere else that has a text input. 
100% reproduceable.
(Reporter)

Comment 1

18 years ago
nominating dogfood.  I can't use bugzilla with this problem.  also clearly
affects top100 e.g. http://www.amazon.com/ and http://www.yahoo.com
Keywords: crash, dogfood, top100

Updated

18 years ago
Keywords: regression
(Reporter)

Comment 2

18 years ago
This problem is not present in 2000-08-23-08 on Linux.
(Reporter)

Comment 3

18 years ago
jst@netscape.com made a huge commit between the first and second build today
that touched string handling everywhere.  CCing him.

Comment 4

18 years ago
Putting on [dogfood+] radar.
Whiteboard: [dogfood+]

Comment 5

18 years ago
can somebody attach a stack trace?
FYI, worksforme, and works in the smoketest builds
(Reporter)

Comment 7

18 years ago
Actually, there is no stack trace, because the nature of the crash is spinning
forever on the CPU.  I could send it a sigint and see where we are spinning.
(Reporter)

Comment 8

18 years ago
Bug is definitely there in Linux 2000-08-23-11, and not there anymore in
2000-08-23-13, which is the latest build at this time.  Guess the streams got
crossed.  Marking WFM.

BTW it is not useful at all when the build ID doesn't match the ftp.mozilla.org
directory name.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
Marking VERIFIED WORKSFORME on:
- LinuxRH62 2000-09-07-08-M18 Commercial
- Win98     2000-09-07-08-M18 Mozilla
- MacOS86   2000-09-07-04-M18 Commercial
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.