MAILTO fields after the first not being parsed

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: jbange, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1) Gecko/20090616 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.22 (20090605)

mailto: links containing more than one ? prefixed field concatenate all field definitions to the first field.

i.e. a link in web page like this:

<a href="mailto: bob@abc.com ?subject=U HAZ WON NIGERIAN LOTTERY ?cc=joe@abc.com ?body=send me U bank infoz>link</a>

will yield a message composition window like this:

To: bob@abc.com
Subject: U HAZ WON NIGERIAN LOTTERY ?cc=joe@abc.com ?body=send me U bank infoz

Changing the order of the fields simply puts the entire string in whichever field is first. 

Reproducible: Always

Steps to Reproduce:
1. paste link above to web page
2. click link
3.
Actual Results:  
mailto: fields after the first are parsed as a literal continuation of the first field.

Expected Results:  
mailto: fields should all be parsed and separated into appropriate edit boxes in composition window
That's not how URLs work - you separate parameters with ampersands, not with more question marks. mailto:bob@abc.com?subject=U%20HAZ%20WON%20NIGERIAN%20LOTTERY&cc=joe@abc.com&body=send%20me%20U%20bank%20infoz
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.