Closed Bug 500322 Opened 12 years ago Closed 12 years ago

"Find" button in download manager does nothing

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set
normal

Tracking

(fennec1.0b3+)

VERIFIED FIXED
fennec1.0b4
Tracking Status
fennec 1.0b3+ ---

People

(Reporter: abillings, Assigned: stechz)

Details

Attachments

(1 file)

If the user downloads a file in Fennec, it will appear in the download manager with its name, size, and the domain that it came from. If the user then selects the "Find" button for this file in the Download Manager, nothing will happen. 

Steps to Reproduce
1. Go to http://www.irs.gov/pub/irs-pdf/fw4.pdf and save the PDF when prompted.
2. Click on the options button in the right pane
3. Click on the download manager button in options
4. On the line for fw4.pdf in the download manager, click on "Find"

Result: Nothing happens
This was found in the beta 2 candidate build from 6/24.
I have verified this bug is an issue on my n810 with a 6/24 build
Assignee: nobody → mark.finkle
tracking-fennec: --- → ?
nsLocalFileUnix ::Reveal() is broken on maemo
tracking-fennec: ? → 1.0b3+
I have not found any decent way to implement ::Reveal()

Since the viewable filesystem is so limited on Maemo, maybe we could just open the File Manager. Not the best "Find".

I am also open to removing this feature altogether.

Thoughts?
im ok with removing
Assignee: mark.finkle → webapps
Can we get this removed (due to comment #4-5), so we don't have duplicate bugs coming in for this issue in the future?
Attachment #397991 - Flags: review?(mark.finkle)
Attachment #397991 - Flags: review?(mark.finkle) → review+
pushed: https://hg.mozilla.org/mobile-browser/rev/873d8e71a69e
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → B4
Forgot to mention, I removed a line of code that was accessing the "show-button" element in the XBL constructor.
verified on n810 with 1.9.2 nightly 20090921
Status: RESOLVED → VERIFIED
Component: Linux/Maemo → General
QA Contact: maemo-linux → general
You need to log in before you can comment on or make changes to this bug.