If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Flash player doesn't work on Firefox/3.5

RESOLVED DUPLICATE of bug 153288

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 153288
8 years ago
8 years ago

People

(Reporter: harry, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090616 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090616 Firefox/3.5

please visit http://www.xinhuanet.com, you will find there is a huge blank on the left top corner of the main page, even the newest version of flash player is installed.

Reproducible: Always

Steps to Reproduce:
1. visit http://www.xinhuanet.com
2. a huge blank rectangle on the top left corner
3. (flash player is installed)
Actual Results:  
huge blank rectangle, but IE works normally

Expected Results:  
as IE
This is no regression in 3.5, this is also in 3.0.11
The code of the iframe :

<SCRIPT type=text/javascript>
	<!--
	var focus_width=610;
	var focus_height=265;
	var text_height=25;
	var swf_height = focus_height+text_height;
	var t=document.getElementById("pictable");
	var rl=t.rows.length;
	var baseu=	document.URL.replace(/(http.*\/)(.*)/, "$1"); 
	var pics="";	var links="";	var texts="";
	for (var i=0;i<rl;i++) {
		pics+=baseu+t.rows[i].cells[0].innerHTML.replace(/\/.*\//, "")+"|";
		links+=t.rows[i].cells[2].innerHTML+"|";
		texts+=t.rows[i].cells[1].innerHTML+"|";
	}
	pics=pics.substr(0,pics.length-1);
	links=links.substr(0,links.length-1);
	texts=texts.substr(0,texts.length-1);
	var fv="pics="+pics+"&links="+links+"&texts="+texts+"&borderwidth="+focus_width+"&borderheight="+focus_height+"&textheight="+text_height;
	document.write('<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="'+focus_width+'" height="'+swf_height+'">');

	document.write('<param name="movie" value="http://imgs.xinhuanet.com/swf/pv.swf"> <param name="quality" value="high"><param name="allowScriptAccess" value="sameDomain"><param name="menu" value="false"><param name="bgcolor" value="#ffffff"><param name="wmode" value="opaque">');

	document.write('<param name="flashvars" value="'+fv+'"></object>');
	//-->
	</SCRIPT>

that makes it to a dupe of bug 153288
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 153288
You need to log in before you can comment on or make changes to this bug.