Can we get a machine with a Via C3 running Windows?

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations: Projects
--
critical
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: Benjamin Smedberg, Assigned: Erica McClure)

Tracking

Details

(Reporter)

Description

9 years ago
Diagnosing bug 500277 it appears that machines running Via C3 chips on Windows are crashing. Since Via C3 chips are still in production and running on various kinda of mobile and low-end hardware I was hoping it would be possible to get one, install Windows XP and try to reproduce this crash. It should probably end up in the QA lab.

The chip needs to be one *without* "VIA padlock", thus the "Samuel 2" or "Ezra/Ezra-T" but not "Nehemiah", at least according to http://en.wikipedia.org/wiki/List_of_VIA_C3_microprocessors.
Assignee: server-ops → sean
Component: Server Operations → Server Operations: Desktop Issues
Approved.

Comment 2

9 years ago
Do you have an example of a machine we can buy which has this CPU? Maybe a netbook or something? A quick search showed only machines with VIA C7-M chips. It's going to be tough to find something shipping with a 7-8 year old CPU.
(Reporter)

Comment 3

9 years ago
I found http://www.newegg.com/Product/Product.aspx?Item=N82E16856107044R and
http://www.newegg.com/Product/Product.aspx?Item=N82E16813153045

although I can't figure out from that page what particular kind of C3 it has inside. I'm pretty sure these processors are still in production. http://www.via.com.tw/en/products/processors/c3/boardlist.jsp has a list of motherboards also, if that helps somehow.

Comment 4

9 years ago
http://www.newegg.com/Product/ComboDealDetails.aspx?ItemList=Combo.201910

Fine getting that. Can you verify it's what you need?
Status: NEW → ASSIGNED
(Reporter)

Comment 5

9 years ago
Talked to their livechat sales rep: they cannot guarantee any particular processor version, and we're likely to end up with a Nehemiah version. A little bit of internet trolling turned up an Ezra processor http://www.alancomputech.com/via-c3-1ghz.html here but I don't know whether it can just be substituted in to any similar socket-370 motherboard or not... boy this computer-buying thing is complicated.

Comment 6

9 years ago
So ( http://www.newegg.com/Product/ComboDealDetails.aspx?ItemList=Combo.201910 ) + ( http://www.alancomputech.com/via-c3-1ghz.html ) + ( fingers crossed ) then?
(Reporter)

Comment 7

9 years ago
Sean, hold on this: I have a couple volunteers with old C3 and K6 processor machines hanging around unused in their basements and such. If one of them turns out to be bootable, they may give us the machine or sell it on the cheap...
(Reporter)

Comment 8

9 years ago
Sean, Mark Tyndall (now cc'ed) has a machine (an AMD K6, which has the same CPU profile we're looking for). Can you contact him to arrange shipment?

Comment 9

9 years ago
Mark, how can I assist?

Comment 10

9 years ago
Ping.
Sean, have you reached out directly?  Mark may be missing bug mail for some reason.

Comment 12

9 years ago
I have no way of knowing what Mark's email address is. :]

I can narrow it down of course to djcater or highmind63, but was hoping someone would chime in either of the times I've pinged.
Sorry, but I'm not the guy you want (highmind63)...

Comment 14

9 years ago
Looking at the history, comment 8 was a lie (the "now cc'ed" part). Now fixed, Mark, read comment 9.

Comment 15

9 years ago
Been AFK this week, sorry.

Do you just want the chip, or the M/B too?
I had it plugged into a Socket 7, Intel 430TX chipset board (ASUS TX97-E)

I assume you can arrange a pick-up from the UK :)

Comment 16

8 years ago
CC'ing Erica on this one to help out with the shipping.
(Assignee)

Comment 17

8 years ago
Hello, can you tell what exactly needs to be shipped: Name, Description, cost, quantity? Also need to know how fast you want all this shipped.

Updated

8 years ago
Assignee: sean → emcclure
(Assignee)

Comment 18

8 years ago
Looking for a response from Mark. Please reply to my emails. Thanks!
How do we get this bug unstuck?  Is this still needed?
Component: Server Operations: Desktop Issues → Server Operations: Projects
(Reporter)

Comment 20

8 years ago
I certainly would like this, yes, assuming Mark is still willing.

Comment 21

8 years ago
Yes, still willing to ship, but still waiting to hear exactly what components you'd like.

I'll assume you want:
CPU - K6-200
M/B - Asus TX97-E
Mem - 256 MB of 168-pin SDRAM (3.3V unbuffered), 2x 128MB sticks
gfx - a PCI graphics card (I think it's a Matrox, BICBW)
HSF - a very basic S7 cooler

Most of the ports (serial, parallel, PS/2 mouse, USB1) are on headers; I can stick those in as well.  NB the keyboard port is AT.

It takes ATX power and parallel ATA HDDs, which I assume you can source in abundance.

Shout up if you want more or less.
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.