Remembered passwords fill in for any page with a password field, ignore the names of the fields

RESOLVED DUPLICATE of bug 499223

Status

()

RESOLVED DUPLICATE of bug 499223
9 years ago
9 years ago

People

(Reporter: drashian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

When a login is saved in Firefox, the browser now automatically fills in that username and password combination for any page that has an input with type="password". If there is a text input on the page, it fills the username (if there are multiple if fills it into the one just above the first password input), but will automatically fill the first password input even if there are no text inputs. I can see that the names of the input fields are still stored in the signons3.txt file, but the password manager no longer appears to use them.

Reproducible: Always

Steps to Reproduce:
1. Sign into a site and select to remember the password.
2. Browse to another page on the site which has a password prompt with a different input name, for example a Change Password / Edit Profile page.
Actual Results:  
On all of the Firefox 3 installations I tested it with, the first password input contained the saved password regardless of its name, and the text input immediately above it contained the username.

Expected Results:  
The fields should be blank, since they are not the same fields that the values were stored for.

This bug doesn't happen in an installation of Firefox 2 I have on a Linux machine, so I believe it showed up some time in Firefox 3.

Updated

9 years ago
Component: Location Bar and Autocomplete → Form Manager
Product: Firefox → Toolkit
QA Contact: location.bar → form.manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499223
You need to log in before you can comment on or make changes to this bug.