If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Setting foreground color then typing doesn't change text color

RESOLVED FIXED

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Simon Fraser, Assigned: saari (gone))

Tracking

Trunk
All
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: possible fix in hand)

(Reporter)

Description

17 years ago
If I change the foreground color using the toolbar wiget, then type, the new text 
does not come out using the new color. It's a if the type-in state is not getting 
the current color.

Comment 1

17 years ago
I don't see this problem on Windows.
I select a color using toolbar widget, then 
immediately type, and it's in the color I just picked. I tried both with caret
inside existing text, and at end of existing text, and in a new page (as first
action - change color).

Comment 2

17 years ago
Look for the line:
window.editorShell.SetTextProperty("font", "color", gColorObj.TextColor);
in editor.js and dump out the color gColorObj.TextColor to be sure you're 
getting the correct value from the colorpicker dialog.

Comment 3

17 years ago
dup of 49952

*** This bug has been marked as a duplicate of 49952 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
uduping; i'm on drugs
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

17 years ago
Simon: I'm still not seeing any problem with today's Window's build.
(Reporter)

Comment 6

17 years ago
The problem here is that on Mac, bringing up the color picker clobbers focus, so 
you have to click back in the document to focus it before typing. This click then 
clobbers the type-in state.

So some focus thing is busted.

Comment 7

17 years ago
handing off to xpfe
Assignee: jfrancis → ben
Status: REOPENED → NEW
Component: Editor → XP Apps: GUI Features
QA Contact: sujay → sairuh

Comment 8

17 years ago
After launching the colorpicker or any other dialog, there are explicit
window._content.focus() calls. Do you see the same problem with other dialogs?
If, as Simon states, there's a focus problem on the Mac, lets file a bug on that 
issue, not on the color setting code.
I don't think this belongs to Ben! Maybe Saari?
Assignee: ben → saari
(Assignee)

Comment 9

17 years ago
window.content.focus calls for which window? The dialog or the content area?

Comment 10

17 years ago
window._content.focus() in the main editor content window.
over to xp widget land [methinks]...
Component: XP Apps: GUI Features → XP Toolkit/Widgets
QA Contact: sairuh → jrgm

Updated

17 years ago
Whiteboard: possible fix in hand

Comment 12

17 years ago
This needs to escalated, else the colorpicker is useless on Mac
(Assignee)

Comment 13

17 years ago
Fixed
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.