Cannot Insert HTML using Composer

VERIFIED DUPLICATE of bug 50034

Status

()

P3
normal
VERIFIED DUPLICATE of bug 50034
18 years ago
17 years ago

People

(Reporter: sol, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using Build 2000-08-23-08, I cannot insert HTML using Composer. I tried both
using the "HTML Source" tab in Composer, and using the "Insert | HTML ..." menu
command from the "Normal" view. In both cases, after saving the document, the
HTML I attempted to insert was not present. (I checked by both previewing the
document and taking a look at the HTML source.

Build ID: 2000-08-23-08 on WinNT 4 (commercial)

Steps to reproduce:
1. Start Seamonkey.
2. Open a new document to edit using Composer (Tasks | Composer)
3. Type some text (e.g., "Last modified ") and leave cursor after this text.
4. Save the document.
5. View the source code for the document. (Click on the "HTML Source" tab at the
bottom of Composer.)
6. Making sure that the cursor is positioned after "Last modified " and enter
the following:
     <script>document.write(document.lastModified);</script>

Note: I could not "Save" the document at this point. Both the Save button and
the File|Save menu items were disabled.

7. Go into the "Normal" view of Composer (Click on the "Normal" tab at the
bottom of Composer.) Enter a space (" ") after the text you typed in Step 3 above.
8. Save the document.
9. Go into the "HTML Source" view of Composer.

Expected: The HTML you entered is still there.
Actual: The HTML has been deleted.

10. From the "Normal" view, use "Insert | HTML ..." to insert the following:
   <script>document.write(document.lastModified);</script>

11. Save the document.
12. View the HTML source (by pressing the "HTML Source" tab at the bottom of
Composer.

Expected: The HTML you entered is still there.
Actual: The HTML has been deleted.

Note that in both steps 9 and 12 I previewed the document in the browser, and
the script I entered (document.lastModified) did not run.
(Assignee)

Comment 1

18 years ago
dup this one

*** This bug has been marked as a duplicate of 50034 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.