incorrect window size and lack of scrollbar when using xslt

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: David Carlisle, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

When xml documents are rendered using the xml-stylesheet PI, they are (apparently) rendered as if to a window that is larger than the actual window size.

The result is that text is not wrapped at the right hand edge, but no horziontal scrollbar appears, similarly text at the bottom of the page is not visible but no scrollbar appears.

If the standard Windows "maximize" and then "restore" buttons are used on the
window then the page is correctly renderd, but if the firefox "reload current page" button is used the rendering reverts to its original bad state.


This used to work in FF 1 and 2 but is broken in FF3 on both windows and linux.



Reproducible: Always

Steps to Reproduce:
1.view http://www.nag.co.uk/numeric/FL/nagdoc_fl22/xhtml/A02/test.xml
2. maximize window
3.  restore window
Actual Results:  
initially (depending on window size) display will look like

http://www.nag.co.uk/numeric/FL/nagdoc_fl22/xhtml/A02/test1.png

after maximizing and restoring to same size, display will correct itself and look like

http://www.nag.co.uk/numeric/FL/nagdoc_fl22/xhtml/A02/test2.png


Expected Results:  
the initial rendering in step 1 should match that in step 3

This test uses a trivial xsl stylesheet (just copy-of on document root)

http://www.nag.co.uk/numeric/FL/nagdoc_fl22/xhtml/A02/test.xsl


but the same problem affects any document using xslt, eg

http://www.nag.co.uk/numeric/FL/nagdoc_fl22/xhtml/A02/a02aaf.xml

http://www.openmath.org/standard/om20-2004-06-30/omstd20html-0.xml


http://www.w3.org/TR/MathML2/overview.xml
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.12pre) Gecko/2009061706 GranParadiso/3.0.12pre

This works fine for me. Maybe caused by an add-on or profile corruption? Please try safe-mode / new profile:
http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Version: unspecified → 3.0 Branch
(Reporter)

Comment 2

9 years ago
I see this on both my machines (and have seen it on other people's), and just confirmed that it still happens in safe mode, however I just tried FF3 on a clean linux machine on which it hadn't previously been used, and did not see the problem
so I am prepared to admit the possibility of a local configuration problem.

Leave as status unconfirmed I will try to reproduce the problem on a clean installation, or if I can't I'll close it as invalid, or at least confirm if it just happens in particular configurations.
(Reporter)

Comment 3

9 years ago
I uninstalled add-ons and tried safe mode, and still the problem persists.

http://www.nag.co.uk/numeric/FL/nagdoc_fl22/xhtml/A02/test3.png

shows the problem on a different machine running a newly installed firefox 3.5 beta running in safe mode.

Comment 4

9 years ago
Well since no one else can reproduce and this doesn't happen with a new profile I'm marking this as WFM until you can produce in a new profile or figure out what exactly in the other profile causes this.  You may have to start toggling all userset preferences in about:config until you find the culprit.  You might also have something in userChrome file that is causing this as safe mode won't disable userChrome until Firefox the release after Firefox 3.5.  Please reopen once you can provide reliable steps to reproduce this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.