Closed Bug 500719 Opened 13 years ago Closed 12 years ago

[VKB]Hard Keyboard and Virtual Keyboard interaction issues with URL Bar.

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set
normal

Tracking

(fennec2.0b2+)

RESOLVED DUPLICATE of bug 592330
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: abillings, Assigned: madhava)

References

Details

(Whiteboard: [fennectestday])

We have some interaction issues with the hard and virtual keyboards and the URL bar with recent changes.

If the hard keyboard is closed and focus is placed on the URL bar, the virtual keyboard opens. If the hard keyboard is then opened, the virtual keyboard is dismissed (correctly). If the hard keyboard is then closed, the soft keyboard does not come back up (bug) (though the text suggestion bar on the bottom goes away so a state change is detected.) The text is completely selected but if the selection is negated, the soft keyboard doesn't come up even though focus is in the URL bar.

In MicroB, if the hard keyboard is closed and focus is placed in the URL bar, the virtual keyboard opens. If the hard keyboard is then opened, the virtual keyboard is dismissed. If the hard keyboard is closed, the soft keyboard does not come up as long as the full text selection is present in the URL bar. If the user clicks in the URL bar (negating selection), the soft keyboard then properly appears. 

Fennec should have the MicroB behavior here.

This was seen on the Maemo build from 6/26.
Whiteboard: [fennectestday]
Duplicate of bug 341772?
I am sorry. I post in wrong bug#.
Flags: wanted-fennec1.0?
The MicroB behaviour makes sense to me, here.  You could argue that, if the text is still selected, you should have the soft keyboard come up when you close the physical one, but if a person is closing an open physical keyboard, it probably means he or she is finished.
Assignee: nobody → madhava
Blocks: 477628
Flags: wanted-fennec1.0?
any status on this?
I'm moving this to blocking as this is a possible outcome and needs to be taken care of. Whether or not it pop-ups isn't the problem. The issue is the fact that the soft keyboard (even when minimized) is completely inaccessible.
tracking-fennec: --- → ?
Flags: wanted-fennec1.0?
Flags: in-litmus?
I don't think this blocks, but Madhava can you specify the ideal behavior in some more detail for anyone who decides to work on it.
tracking-fennec: ? → 1.0-
Madhava, can we take another look at this?
tracking-fennec: 1.0- → ?
Component: Linux/Maemo → General
tracking-fennec: ? → 2.0b2+
Duplicate of this bug: 588541
Flags: in-litmus? → in-litmus?(nhirata.bugzilla)
Summary: Hard Keyboard and Virtual Keyboard interaction issues with URL Bar. → [VKB]Hard Keyboard and Virtual Keyboard interaction issues with URL Bar.
bug 592330 has the desired behavior
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 592330
minusing the litmus in favor of creating testcases based on bug 592330
Flags: in-litmus?(nhirata.bugzilla) → in-litmus-
You need to log in before you can comment on or make changes to this bug.