Facebook bottom bar floats instead of respecting the bottom of the window

VERIFIED DUPLICATE of bug 607417

Status

VERIFIED DUPLICATE of bug 607417
9 years ago
7 years ago

People

(Reporter: aakashd, Assigned: stechz)

Tracking

Trunk
x86
Windows XP

Details

(Whiteboard: [fennectestday])

(Reporter)

Description

9 years ago
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090626 Fennec/1.0b2

Steps to Reproduce:
1. Log into www.facebook.com
2. Scroll down.
3. Use the bottom bar functionalities.

Actual Results:
bottom bar floats

Expected Results:
bottom bar "sticks" to the bottom.
(Reporter)

Updated

9 years ago
Severity: major → normal
Whiteboard: [fennectestday]
verified with 6/26 nightly rc build for maemo (it is difficult to get regular vs. mobile facebook on maemo, but it is possible)
sounds like bug 475678
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475678
this is not a dup of bug 475678.  On the maemo nightly build from 20090819, I log into facebook and the bar scrolls with me.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
tracking-fennec: --- → ?

Updated

9 years ago
tracking-fennec: ? → 1.0+
I seem to remember that romaxa said this bug could be caused by Fennec not setting the right scrollX/scrollY of the browser when we pan the tiles.
(Assignee)

Updated

9 years ago
Assignee: nobody → webapps
(Assignee)

Comment 5

9 years ago
Part of this bug is expected, technically speaking.  Although we do need to update browser scrollbox, the browser never knows about our zoom level.  So at any zoom level that isn't 1.0 Facebook (or any other site) will wrongly assume the viewport is something it is not.

Since Facebook's site is meant to render at a minimum of 1024px width and we zoom the page to fit the width, the bottom bar is shown at the wrong location.
(Assignee)

Comment 6

9 years ago
I see nothing we can do about this bug, assuming we continue to zoomToFit and keep our default rendering width as 800.  Websites aren't always going to render well on mobile browsers, and Facebook already has a mobile website.

We should probably mark this as not blocking 1.0 or close it as WONTFIX.

Updated

9 years ago
tracking-fennec: 1.0+ → 1.0-
(Assignee)

Updated

9 years ago
Assignee: webapps → nobody
(Reporter)

Comment 7

9 years ago
This is also found on reuters now
we should really reconsider this for 1.0.  This looks very crappy and it blocks functionality.  For example, the bar is floating over a "comment" button, so I can enter the comment into the textarea, but not hit submit.
(Reporter)

Comment 9

9 years ago
This is also seen for the feedback button at http://www.teachstreet.com/mountain-view-ca/66908 (it'll be on the right side)
For Microb I did fixed-Position elements hiding during scrolling...
But this is not very good solution, we should not just hide, but move fixed elements in separate layer, and composite it on top of scrolled area.
(Reporter)

Updated

9 years ago
tracking-fennec: 1.0- → ?
(Reporter)

Updated

9 years ago
Duplicate of this bug: 567842
Assignee: nobody → webapps
tracking-fennec: ? → 2.0b1+
Depends on: 576192
Duplicate of this bug: 567842

Comment 15

8 years ago
Same issues is on Youtube page as there is Video Queue Panel with fixed position. it does not stick to bottom.

Updated

8 years ago
tracking-fennec: 2.0b1+ → 2.0b2+
abs position is a post 2.0 feature.
tracking-fennec: 2.0b2+ → 2.0-

Comment 17

8 years ago
This issue is reproducible only when browser.tabs.remote=true on latest nightly build. Checked with browser.tabs.remote=false and it is not reproducible.
I'd like to dup this to bug 607417.  Please let me know if there are reasons not to.

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 607417

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.