Closed Bug 500758 Opened 10 years ago Closed 9 years ago

recently closed tabs in the go menu

Categories

(Thunderbird :: Toolbars and Tabs, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: clarkbw, Assigned: schmid-thomas)

Details

(Keywords: student-project, Whiteboard: [3.next add-on idea], ucosp)

With the new tab search landed I think we should take a quick lesson from Firefox and implement the recently closed tabs menu.

I think we can parent this at our Go menu, placing it at the very bottom.  Here are some examples.

* First load or no closed tabs
Go -> Recently Closed Tabs -> ( none )

* Only one closed tab
Go -> Recently Closed Tabs -> Search: "david ascher"  ctrl-shift-t

* More than one closed tab
Go -> Recently Closed Tabs -> Search: "blake winton"  ctrl-shift-t
                              Search: "david ascher"
                              ----------------------
                              _O_pen all in tabs

Order of closed tabs is listed in most recent at the top to least recent at the bottom.  The list of tabs does not need to persist beyond the thunderbird session.

Despite not having a ctrl-t open new tab yet (bug 458069) I think we can use ctrl-shift-t as our key binding for bringing back a closed tab.

In talking with asuth this should be really easy once you've hooked into a tab close event.  Ask each closing tab for it's session state, which should be returned as a json object and save that object in the menu list.  Then you restore and open the tab who's menu item has been clicked.

If a tab doesn't know how to restore itself we can just ignore it from the recently closed tabs list since we can't do anything with it.  It might be nice to log that as an error somewhere to help in debugging of extensions that implement tabs incorrectly.

This would probably be a really good first bug or student project as the code is simple and in really good shape and the requirements are also pretty simple.
This might want to be duped against bug 504122 if that bug is going to take on this piece as well as the undo close tab part.
Whiteboard: [3.next add-on idea]
Is anyone interested to contribute in a team to work on solving this bug??

looking forward to achieve this. :)
I need to know the maximum number of tabs to be available as recently closed tabs.
It looks like Firefox isn't setting a limit on the number to show so perhaps the limit is actually in the number of tabs saved in the undo stack.

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-places.js#610

On the Mac I can only see the last 10 tabs in the Firefox undo so lets start with that and go from there.
I'll work on 'undo last closed tab', then hopefully a menu like this with multiple recently closed tabs.
Assignee: nobody → zgchurch
Status: NEW → ASSIGNED
Whiteboard: [3.next add-on idea] → [3.next add-on idea], ucosp
(In reply to comment #5)
> I'll work on 'undo last closed tab', then hopefully a menu like this with
> multiple recently closed tabs.

It seems to me as if this bug is a duplicate of 504122? 

Bug 468808 implements a simple undo closed tabs as somekind of side effect with reordering tabs. But it can be just accessed via the context menu, no menu entries. Might be a good starting point.
Fixed in Bug 504122.
Assignee: zgchurch → schmid-thomas
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.