Controls do not work correctly with audio or video files over ~10 hours

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: gmaxwell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

The built in controls for ogg files behave strangely for files with durations over ~10 hours but with sizes under 2^31 bytes (files over 2^31 bytes are unseekable, but thats another bug)

For example http://metavidcapture.ucsc.edu/raw_mpeg2/senate_proceeding_04-23-09.ogg

In this case the seek can only be moved to the *left* of the starting point.

Or,
http://myrandomnode.dyndns.org:8080/~gmaxwell/firefox/bach.truncated.ogg

Where only the first 9 hours are reachable and the playhead moves off the end of the control.



Reproducible: Always




Tested on Linux and Mac

Comment 1

9 years ago
This does look controls specific - seeking works if you use the JavaScript API directly on the video.

Comment 2

9 years ago
Isn't this a duplicate of #500784?
(Reporter)

Comment 3

9 years ago
No. Its a separate and distinct issue. It has nothing to do with the number of bytes in a file and I specifically provided an examples less than 2GB in size to differentiate these two failure modes.  It's also limited to controls behaviour, whereas the other issue is more general.
I can't reproduce this on trunk.  Is anyone else still seeing it?
(Reporter)

Comment 5

9 years ago
This was fixed at some point.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio
You need to log in before you can comment on or make changes to this bug.