If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Forum list by category does not include all posts

VERIFIED FIXED

Status

quality.mozilla.org
Website
P1
critical
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: marcia, Assigned: aakashd)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
Despite the fact that there is a notation that coop posted something 1 hour ago, the page is empty when I load it and no threads show.
(Assignee)

Comment 1

8 years ago
Yep, seeing the same thing. cc'ing paul on this.
OS: Windows NT → All
Hardware: x86 → All
I posted a forum topic and it shows up:
http://quality.mozilla.org/forums/quality-assurance-discussion/code

What exactly is the issue?
Assignee: nobody → paul.craciunoiu
(Assignee)

Comment 3

8 years ago
If you go back to http://quality.mozilla.org/forums/quality-assurance-discussion

You'll see 2 topics listed under "code", but there's only one visible one now. Not sure whats going on.

Updated

8 years ago
Priority: -- → P1
(Reporter)

Comment 4

8 years ago
There is definitely data loss going on here.  Unless forum posts are supposed to disappear after some time, the posts by coop and previous posters are gone. Or somehow something got overwritten in that area.
Severity: normal → critical
Target Milestone: --- → 1.0
Summary: http://quality.mozilla.org/forums/quality-assurance-discussion/code is blank → Forum list by category does not include all posts
I couldn't reproduce this locally. Not sure what's going on. It'll take a while to figure it out, I'll investigate more next week.
I resaved [1] and it now shows up at [2]. Same for [3] and [4] showing up at [5]. Something must've happened in the save process. If there are others, try this method and if it doesn't work please post a URL here with STR (especially if it's consistent).

Marking this fixed.

[1] http://quality.mozilla.org/projects/improving-litmus
[2] http://quality.mozilla.org/forums/quality-assurance-discussion/code
[3] http://quality.mozilla.org/projects/webdev-qa
[4] http://quality.mozilla.org/events/2009/jul/16/testing-thunderbird-30-beta-3
[5] http://quality.mozilla.org/forums/quality-assurance-discussion/test
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Go to:
http://quality.mozilla.org/admin/content/node
And filter by "-Project-Discussion" category. You will see there are 18 posts (ass shown at http://quality.mozilla.org/forums/mozilla-qa-community for that category). However, going to:
http://quality.mozilla.org/forums/mozilla-qa-community/projects
Shows only 13.

This can be fixed by resaving the posts that do not show up. (if they still don't show up, try unchecking "Create new revision")

If this still occurs, please-please post here STR, especially if you can manage to reproduce it consistently. If anyone has time, this should be experimented with on staging. Also, if you notice something in common to all the posts that do not show up, let me know.

Aakash, have some time to resave 5 posts? :)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 504349
Assignee: paul.craciunoiu → adesai
(Assignee)

Comment 9

8 years ago
the posts have been re-saved and checked against the project-discussions forum :).

Moving to resolved:fixed.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

8 years ago
Target Milestone: 2.0 → ---
You need to log in before you can comment on or make changes to this bug.