Firefox can crash if the preference general.useragent.extra.firefox is defined in pref.js

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: skmail, Unassigned)

Tracking

({stackwanted})

1.9.1 Branch
x86
Windows XP
stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 FoxOnFlames
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 FoxOnFlames

If general.useragent.extra.firefox is defined, even if the string is empty (''), Firefox will crash on http://www.art-meter.com/blog/cat/. Tested with a new (empty) Firefox profile and latest official 3.5 version.

Reproducible: Always

Steps to Reproduce:
1. In prefs.js set preference general.useragent.extra.firefox to any value
2. Start Firefox
3. Visit http://www.art-meter.com/blog/cat/
Actual Results:  
Firefox will crash.

Expected Results:  
Should be no question is that case.
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

Comment 2

9 years ago
WFM.  In addition to comment 1, could you please also post your Build ID (Help -> About Firefox, copy and paste the entire Build ID
(Reporter)

Comment 3

9 years ago
Build ID was already posted, see above (Build Identifier)
Here once more:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 FoxOnFlames

You can always get the stack trace by following the 'Steps to Reproduce'.

Comment 4

9 years ago
As I said, I can't reproduce this so I can't get a stack trace.  We need your stack trace before we can even attempt to do anything here since no one else can reproduce this.
(Reporter)

Comment 5

9 years ago
I tried to get a crash report with an empty profile but I failed because the crash reporter was not invoked. 
To resolve the crash reporter issue I updated the Flash plugin von version 9 to 10 as recommended on https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report. 
With the Flash update Bug 500878 was resolved too. 

Note that - although using en empty Firefox profile - the Flash plugin was still loaded into Firefox (from an Opera subdirectory).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: General → Plug-ins
Keywords: stackwanted
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.9.1 Branch
You need to log in before you can comment on or make changes to this bug.