Thunderbird compacts folders despite configuration to only mark as deleted

RESOLVED DUPLICATE of bug 484445

Status

RESOLVED DUPLICATE of bug 484445
9 years ago
9 years ago

People

(Reporter: mcepl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4
Build Identifier: thunderbird-3.0-2.3.beta2.fc11.i586

(originally filed as https://bugzilla.redhat.com/show_bug.cgi?id=507911)

I have my email account configured to only mark messages as deleted in
Thunderbird.  When checking for new messages (though not every time),
thunderbird compacts (ie expunges) the deleted messages from the inbox and
other folders.

Thunderbird will compact folders at least once a day.  However, it does not
appear to compact every time it checks for new email.  It is not clear what the
interval is.

Reproducible: Always

Steps to Reproduce:
1.  Configure Thunderbird to 'mark message deleted' (Account Settings -> Server
Settings).  Make sure 'Clean up Inbox on exit' is not checked.
2.  Mark some messages as deleted.
3.  Check for new email.  Repeat until folders are compacted.

Actual Results:  
Thunderbird will compact folders despite configured not to do so.


Expected Results:  
I mark messages as deleted and, at some later point, instruct Thunderbird to
compact folders.


This behavior does not exist in Fedora 10 and Thunderbird 2.  I obtain the
expected results with Thunderbird 2 (thunderbird-2.0.0.21-1.fc10.i386).

Comment 1

9 years ago
This sounds like bug 484445, followed up on by bug 490934. Neither of those is fixed in 3.0 beta 2, but you shouldn't see the behavior in a beta 3 nightly.

Also, changing mail.imap.expunge_threshold_number to a large number should limit the impact (the default is 20, set it to 2000 or similar).

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 484445
You need to log in before you can comment on or make changes to this bug.