All users were logged out of Bugzilla on October 13th, 2018

when searching and then going back to page to search again

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: dina.shvayakova, Assigned: dina.shvayakova)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.0.11) Gecko/2009060308 Ubuntu/9.04 (jaunty) Firefox/3.0.11
Build Identifier: 

The 'Search' label is always visible after page load, even when there is a text in input box.

Reproducible: Always

Steps to Reproduce:
1.Type the text in quick-search input box 
2.Click search 
3.Go Back to Mozilla site
Actual Results:  
there are 'Search' label and text to search in input box overlapping 

Expected Results:  
only the request text should be in the search input box
(Assignee)

Comment 1

9 years ago
Created attachment 385652 [details] [diff] [review]
script patch

The solution is attached.

Added check when the page is reloaded and request text is not empty.

Comment 2

9 years ago
I just checked in this change.  It should show up on the staging site in a few minutes and we can test it then to see if it fixes this issue.

Comment 3

9 years ago
I just tested this on the staging site and the problem with the search box seems to be fixed.  Thanks tinawiel for the patch.  If anyone else wants to check this, please feel free to verify.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 4

9 years ago
Comment on attachment 385652 [details] [diff] [review]
script patch

Reed, could you take a look over this?  I checked it into the staging site and it works, but I realize someone more familiar with JS than I am should review it.
Attachment #385652 - Flags: review?(reed)
Attachment #385652 - Flags: review?(reed)
Assignee: nobody → dina.shvayakova
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.