[HTML5] Address code style comments from timeless

RESOLVED FIXED

Status

()

Core
HTML: Parser
--
trivial
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: hsivonen, Assigned: hsivonen)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
NS_ASSERTION((!loadAsHtml5) has pointless parentheses still. Get rid of them.
(Assignee)

Comment 1

9 years ago
Morphing the bug to be more general, because dealing with each comment individually would lead to a ton of one-line patches to review and check in.

This is now a catch-all for parentheses, indents and comments.
Summary: [HTML5] Remove pointless parentheses in assert → [HTML5] Address code style comments from timeless
(Assignee)

Updated

9 years ago
Duplicate of this bug: 501013
(Assignee)

Updated

9 years ago
Duplicate of this bug: 501011
(Assignee)

Comment 4

9 years ago
Created attachment 386054 [details] [diff] [review]
Patch addressing comments from timeless

Not included:
 * Stuff that involves changing the translator.
 * Stuff that has dedicated bugs.
 * Stuff that would make it more difficult to transform the Java code to use Mozilla-style write params for string returns.
 * Use of contract id in place of class id.
(Assignee)

Updated

9 years ago
Attachment #386054 - Flags: superreview?(mrbkap)
Attachment #386054 - Flags: review?(jonas)

Updated

9 years ago
Attachment #386054 - Flags: superreview?(mrbkap) → superreview+
(Assignee)

Updated

9 years ago
Duplicate of this bug: 503068
(Assignee)

Comment 6

9 years ago
Comment on attachment 386054 [details] [diff] [review]
Patch addressing comments from timeless

mrbkap, requesting r, since it seems sr isn't what's needed for this, but I think it would be inappropriate for me just treat your sr as an r.
Attachment #386054 - Flags: review?(jonas) → review?(mrbkap)

Updated

9 years ago
Attachment #386054 - Flags: review?(mrbkap) → review+
(Assignee)

Comment 7

9 years ago
Pushed. http://hg.mozilla.org/mozilla-central/rev/712073dde3c0
Thanks!
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.