Better signatures for crashes which have nsCOMPtr<something>::<something> as the top frame

RESOLVED DUPLICATE of bug 530684

Status

Socorro
General
--
enhancement
RESOLVED DUPLICATE of bug 530684
9 years ago
6 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
As asuth notes in bug 445372 comment 3 "nsCOMPtr is a reference-counting pointer wrapper.  The bug will never be in nsCOMPtr, it will just be where the crash happens.  Ideally crash-stats would filter it out."  So we would want better signatures for crashes which have nsCOMPtr<something>::<something> as the top frame - as was done for bug 411349.

http://crash-stats.mozilla.com/report/list?product=Thunderbird&version=Thunderbird%3A3.0b3pre&query_search=signature&query_type=contains&query=nsCOMPtr_base%3A%3Aassign_with_AddRef&date=&range_value=15&range_unit=days&do_query=1&signature=nsCOMPtr_base%3A%3Aassign_with_AddRef%28nsISupports*%29 lists the crashes for an example subset of nsCOMPtr_base::assign_with_AddRef.  Note, in about half of the crashes, the second frame does not have a module name (eg bp-57ec716b-7e4a-47d1-9cad-211552090626 ) or a line number for the module (eg bp-7c764d27-45e3-48cb-b274-63d482090627 ).

bugs citing nsCOMPtr* - https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=nsCOMPtr&product=Core&product=Firefox&product=MailNews+Core&product=Thunderbird&resolution=FIXED&resolution=---&bug_severity=critical&chfieldto=Now

reference bug 445372
(Reporter)

Updated

8 years ago
Depends on: 522782
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 530684
(Assignee)

Updated

6 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.