searching phonebook crashes browser

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Tom Everingham, Assigned: David P. Drinan)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+])

(Reporter)

Description

18 years ago
Overview Description:  When I search for a name in phonebook I crash.  I am 
using the test proxy frame.packetgram.com which is on the public network so I 
would think this shouldn't work.  But it definitely shouldn't crash the browser.   

Steps to Reproduce:
1.)  go to http://phonebook
2.)  search for a number

Actual Results:  crash

Expected Results:  I think you should get a message such as 'the requested 
operation could not be performed by the proxy.'

Build Date & Platform Bug Found:
WinNT 2000082308

Additional Information:
talkback report:

MSVCRT.dll + 0x10f8d (0x78010f8d) 
nsSecureBrowserUIImpl::OnStateChange 
[d:\builds\seamonkey\mozilla\extensions\psm-glue\src\nsSecureBrowserUIImpl.cpp, 
line 368]
nsDocLoaderImpl::FireOnStateChange 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 1256]
nsDocLoaderImpl::doStopDocumentLoad 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 711]
nsDocLoaderImpl::DocLoaderIsEmpty 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 615]
nsDocLoaderImpl::OnStopRequest 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 545]
nsLoadGroup::RemoveChannel 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp, line 573]
nsDocShell::CreateContentViewer 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2539]
nsDSURIContentListener::DoContent 
[d:\builds\seamonkey\mozilla\docshell\base\nsDSURIContentListener.cpp, line 101]
nsDocumentOpenInfo::DispatchContent 
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 362]
nsDocumentOpenInfo::OnStartRequest 
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 234]
nsHTTPFinalListener::OnStartRequest 
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 1115]
nsHTTPServerListener::FinishedResponseHeaders
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 1053]
nsHTTPServerListener::OnDataAvailable 
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 425]
nsOnDataAvailableEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
406]
nsStreamListenerEvent::HandlePLEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
106]
PL_HandleEvent 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 588]
_md_EventReceiverProc 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1045]
(Reporter)

Comment 1

18 years ago
adding crash keyword
Keywords: crash

Comment 2

18 years ago
According to the stack trace the crash it inside of PSM
Assignee: ruslan → gagan

Comment 3

18 years ago
->ddrinan
Assignee: gagan → ddrinan
PSM is crashing in phonebook even though I am not using a proxy server.
To reproduce:
go to phonebook
enter a email address, hit enter
PSM crashes
phone number is NOT displayed

expected results:
phone number should be displayed.

This is a dogfood issue for me. To look up a phone number I have to use Nav 4.x.

Adding dogfodd, rtm keywords
Keywords: dogfood, rtm

Comment 5

17 years ago
Updating summary line, since recent report of of crash without proxy.
Marking dogfood-plus for this case.
If this were only with the odd proxy, stress testing the system, this would not
have been a dogfood plus.
Summary: using SSL proxy and searching phonebook crashes browser → searching phonebook crashes browser
Whiteboard: [dogfood+]

Comment 6

17 years ago
If this is actually being worked on, please put [rtm need info] in the status 
whiteboard.  Is there something special required to hit this?  A couple of this 
have noted that we can get to phonebook and aka without crashing (including 
giving the password for the cert.)

Does it require using SERA or are you going to it as an invalid destination?
Whiteboard: [dogfood+] → [dogfood+][need info]

Comment 7

17 years ago
I use the phonebook about 20 times/day and don't crash.  What else might be a
trigger here?

tever: do you still have this problem? Also, can you visit other SSL sites
without crashing?

Comment 8

17 years ago
I think that this problem has been fixed in more recent builds.

Marking WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Whiteboard: [dogfood+][need info] → [dogfood+]
(Reporter)

Comment 9

17 years ago
verified wfm on branch:
winNT 1023 build

needs verified on trunk
Keywords: vtrunk

Comment 10

17 years ago
Verified on trunk commercial build 102404.
Status: RESOLVED → VERIFIED
Keywords: vtrunk

Comment 11

17 years ago
verified on the 20001024 branch build. on win2000, win98
You need to log in before you can comment on or make changes to this bug.