Segmentation fault on Thunderbird when pasting text from SQLDeveloper [@ libc-2.9.so@0x77078]

RESOLVED DUPLICATE of bug 495392

Status

()

Core
Editor
--
critical
RESOLVED DUPLICATE of bug 495392
9 years ago
7 years ago

People

(Reporter: Michal, Unassigned)

Tracking

({crash})

1.9.1 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.11) Gecko/2009060308 Ubuntu/9.04 (jaunty) Firefox/3.0.11
Build Identifier: Thunderbird version 2.0.0.22 (20090608)

There is always Segmentation fault when pasting any block of text from Oracle SQLDeveloper to Thunderbird. There is no problem with pasting text to other programgs. I'm having this problem on Ubuntu 9.04

Reproducible: Always

Steps to Reproduce:
1.Download and Install SQLDeveloper:  http://www.oracle.com/technology/software/products/sql/index.html
2. Connecto to any server and type any text for example :"select 1 from dual;"
3. Then select and copy this text: "select 1 from dual;"
4. Open "Write mail"
5. Paste text
6. We have Segmentation Fault
Actual Results:  
Segmentation Fault

Expected Results:  
Paste text into window with new mail

System: Ubuntu 9.04

Updated

9 years ago
Severity: normal → critical
Keywords: crash
Thanks for the report.
Do you get this crash when pasting into Firefox?
Does it make a difference whether you paste with middle mouse button or Edit->Paste?
Depends on: 495392
(Reporter)

Comment 2

9 years ago
Paste to Firefox (ctrl+v): Works OK,
Paste to Firefox (shift+insert): Works OK,
Paste to Firefox (middle button):  Works OK,

Paste to Thunderbird (ctrl+v): crash,
Paste to Thunderbird (shift+insert): crash,
Paste to Thunderbird (middle button):  crash,
Paste to Thunderbird (Edit->paste):  crash,

After every crash I have to run thunderbird in --safe-mode, because otherwise it crashes on startup.
Comparison with Firefox 3.0 isn't very useful - the back end is different to Thunderbird 2.0. You could compare Firefox 2 with Thunderbird 2 or Firefox 3.5 with the beta builds of Thunderbird 3.
(Reporter)

Comment 4

9 years ago
Sorry,  I've downloaded  Thunderbird 3 beta 3:

Paste to Thunderbird (ctrl+v): crash,
Paste to Thunderbird (shift+insert): crash,
Paste to Thunderbird (middle button):  crash,
Paste to Thunderbird (Edit->paste):  crash,

On console showed up messages :

(crashreporter:8229): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion `GTK_IS_WIDGET (widget)' failed

(crashreporter:8229): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion `GTK_IS_WIDGET (widget)' failed

(crashreporter:8229): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion `GTK_IS_WIDGET (widget)' failed



Log generated by crashreporter


Add-ons: {972ce4c6-7e08-4474-a285-3208198ce6fd}:2.0
BuildID: 20090715134828
CrashTime: 1249304482
InstallTime: 1249304250
ProductName: Thunderbird
StartupTime: 1249304276
Theme: classic/1.0
Throttleable: 1
Vendor: 
Version: 3.0b3
Can you get the actual crash id: http://kb.mozillazine.org/Breakpad ?
(Reporter)

Comment 6

9 years ago
For example: bp-3fe1c940-f825-47e7-b40e-7143e2090803  (http://crash-stats.mozilla.com/report/index/3fe1c940-f825-47e7-b40e-7143e2090803)
0  	libc-2.9.so  	libc-2.9.so@0x77078  	
1 	thunderbird-bin 	nsHTMLEditor::HavePrivateHTMLFlavor 	editor/libeditor/html/nsHTMLDataTransfer.cpp:1844
2 	thunderbird-bin 	nsHTMLEditor::Paste 	editor/libeditor/html/nsHTMLDataTransfer.cpp:1869
3 	thunderbird-bin 	nsPasteCommand::DoCommand 	editor/libeditor/base/nsEditorCommands.cpp:418
4 	thunderbird-bin 	nsControllerCommandTable::DoCommand 	embedding/components/commandhandler/src/nsControllerCommandTable.cpp:191
5 	thunderbird-bin 	nsBaseCommandController::DoCommand 	embedding/components/commandhandler/src/nsBaseCommandController.cpp:169
6 	thunderbird-bin 	DoCommandCallback 	content/xbl/src/nsXBLWindowKeyHandler.cpp:315
7 	thunderbird-bin 	paste_clipboard_cb 	widget/src/gtk2/nsNativeKeyBindings.cpp:211
8 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0x183a3 	
9 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0xac7a 	
10 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0x20e56 	
11 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x7066f 	
12 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x70c2b 	
13 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x70e9c 	
14 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x71222 	
15 	thunderbird-bin 	nsNativeKeyBindings::KeyPressInternal 	widget/src/gtk2/nsNativeKeyBindings.cpp:339
16 	thunderbird-bin 	nsNativeKeyBindings::KeyPress 	widget/src/gtk2/nsNativeKeyBindings.cpp:283
17 	thunderbird-bin 	nsXBLWindowKeyHandler::WalkHandlers 	content/xbl/src/nsXBLWindowKeyHandler.cpp:381
18 	thunderbird-bin 	nsXBLWindowKeyHandler::KeyPress 	content/xbl/src/nsXBLWindowKeyHandler.cpp:419
19 	thunderbird-bin 	nsEventListenerManager::HandleEvent 	content/events/src/nsEventListenerManager.cpp:184
20 	thunderbird-bin 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventDispatcher.cpp:236
21 	thunderbird-bin 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:324
22 	thunderbird-bin 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:354
23 	thunderbird-bin 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:514
24 	thunderbird-bin 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:6317
25 	thunderbird-bin 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6117
26 	thunderbird-bin 	nsViewManager::HandleEvent 	view/src/nsViewManager.cpp:1400
27 	thunderbird-bin 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1359
28 	thunderbird-bin 	HandleEvent 	view/src/nsView.cpp:168
29 	thunderbird-bin 	nsWindow::DispatchEvent 	widget/src/gtk2/nsWindow.cpp:577
30 	thunderbird-bin 	nsWindow::OnKeyPressEvent 	widget/src/gtk2/nsWindow.cpp:3305
31 	thunderbird-bin 	key_press_event_cb 	widget/src/gtk2/nsWindow.cpp:5696
32 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x136525 	
33 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0xac7a 	
34 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0x20e56 	
35 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0x2234e 	
36 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0x22935 	
37 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x2512ad 	
38 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x26511e 	
39 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x26849b 	
40 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x136525 	
41 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0x93d8 	
42 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0xac7a 	
43 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0x20afe 	
44 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0x2234e 	
45 	libgobject-2.0.so.0.2000.1 	libgobject-2.0.so.0.2000.1@0x22935 	
46 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x2512ad 	
47 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x12f040 	
48 	libgtk-x11-2.0.so.0.1600.1 	libgtk-x11-2.0.so.0.1600.1@0x130326 	
49 	libgdk-x11-2.0.so.0.1600.1 	libgdk-x11-2.0.so.0.1600.1@0x4a349 	
50 	libglib-2.0.so.0.2000.1 	libglib-2.0.so.0.2000.1@0x39b87 	
51 	libglib-2.0.so.0.2000.1 	libglib-2.0.so.0.2000.1@0x3d0ea 	
52 	libglib-2.0.so.0.2000.1 	libglib-2.0.so.0.2000.1@0x3d267 	
53 	thunderbird-bin 	nsBaseAppShell::DoProcessNextNativeEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:151
54 	thunderbird-bin 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:296
55 	libxpcom_core.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:497
56 	libxpcom_core.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:227
57 	thunderbird-bin 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
58 	thunderbird-bin 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:193
59 	thunderbird-bin 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3298
60 	thunderbird-bin 	main 	mail/app/nsMailApp.cpp:103
61 	libc-2.9.so 	libc-2.9.so@0x16774
Summary: Segmentation fault on Thunderbird when pasting text from SQLDeveloper → Segmentation fault on Thunderbird when pasting text from SQLDeveloper @[libc-2.9.so@0x77078]
Component: Message Compose Window → Editor
Product: Thunderbird → Core
QA Contact: message-compose → editor
Version: unspecified → 1.9.1 Branch
Thanks, looks like the same issue as bug 495392.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
No longer depends on: 495392
Resolution: --- → DUPLICATE
Duplicate of bug: 495392

Updated

9 years ago
Summary: Segmentation fault on Thunderbird when pasting text from SQLDeveloper @[libc-2.9.so@0x77078] → Segmentation fault on Thunderbird when pasting text from SQLDeveloper [@ libc-2.9.so@0x77078]
(Assignee)

Updated

7 years ago
Crash Signature: [@ libc-2.9.so@0x77078]
You need to log in before you can comment on or make changes to this bug.