Trailing comma in tag is retained

VERIFIED FIXED in 5.0.7

Status

VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: yem.huynh)

Tracking

unspecified
5.0.7
x86
Mac OS X

Details

(Whiteboard: [webmocha])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 385780 [details]
comma

steps to reproduce:
1.Log in to your AMO account.
2.Navigate to any add-on page
3.Click on "Add a atg" link
4.Enter "test,blah," as tags and click add

expected result:
the redundant trailing comma is ignored

actual result:

Comma is also saved(see attached image)
Assignee: nobody → mikelee
I had the idea that  we should whack this along with trim()ing the tags, but making a special case for commas over other punctuation seems lame.  ->wontfix
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
we're delimiting on commas ->reopen
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

9 years ago
Assignee: mikelee → expatrick
Whiteboard: [webmocha]

Updated

9 years ago
Assignee: expatrick → yem.huynh
This is already fixed, right?
(In reply to comment #3)
> This is already fixed, right?

Looks like this bug has turned into "trailing comma adds a blank tag" - for the record, a tag should never be blank.  Just make the split function remove anything that is blank.
(Assignee)

Comment 5

9 years ago
Created attachment 386675 [details] [diff] [review]
fix

ignore empty spaces. so the following:

,aaa,  ,bbb,  ,,,cccc,

will only create tags:

aaa
bbb
ccc
(Assignee)

Updated

9 years ago
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
A similar patch is committed in r29326
(Reporter)

Comment 7

9 years ago
verified
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.