Monitor Preferences no longer retained on browser shutdown/restart - Core

RESOLVED DUPLICATE of bug 465240

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 465240
9 years ago
9 years ago

People

(Reporter: aaronstein, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090629 Shiretoko/3.5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090629 Shiretoko/3.5pre

on a 2 monitor system, if firefox is moved to the non primary monitor and then closed. the reopen always happens on the primary monitor, the setting is not retained. This behavior changed since RC1. Prior builds retained the display preference and would open on the last location, broke recently

Reproducible: Always

Steps to Reproduce:
1.on a multi display system, open firefox
2.move firefox to a secondary display
3.close and reopen firefox, the display preference is lost.
Actual Results:  
Firefox opens on primary display

Expected Results:  
Firefox should open on last display used - ie secondary.
Component: Shell Integration → Preferences
QA Contact: shell.integration → preferences
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465240
You need to log in before you can comment on or make changes to this bug.