SM 2 trunk has quit honoring startup "mail and news" pref

VERIFIED FIXED in seamonkey2.0b1

Status

SeaMonkey
Startup & Profiles
--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Robert Roessler, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey2.0, regression})

Trunk
seamonkey2.0b1
fixed-seamonkey2.0, regression
Bug Flags:
blocking-seamonkey2.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
With the SM 2 trunk nightly for 20090629, the configured pref to start mail and news on open has quit working - the SM 2 trunk nightly from 20090627 still honored the pref.

Now, a browser window comes up, and you are required to enter the master password, but no mail and news window is started unless I use the bottom-left toolbar button.

Vista SP2 x64 with 4GB.

Updated

9 years ago
Flags: blocking-seamonkey2+
(Assignee)

Updated

9 years ago
Blocks: 467768
(Assignee)

Comment 1

9 years ago
Created attachment 386247 [details] [diff] [review]
Proposed patch
Attachment #386247 - Flags: superreview?(bienvenu)
Attachment #386247 - Flags: review?(mnyromyr)

Updated

9 years ago
Attachment #386247 - Flags: superreview?(bienvenu) → superreview+

Updated

9 years ago
Duplicate of this bug: 501534

Updated

9 years ago
Assignee: nobody → neil
OS: Windows Vista → All
Hardware: x86 → All
(Assignee)

Comment 3

9 years ago
Hmm, I'm usually good about reassigning myself the bug when I attach a patch...
Status: NEW → ASSIGNED
In reply to comment #0
In the meantime, invoking "seamonkey -mail" (whether from the command-line or from a desktop icon) will still load only the mail/news client (disregarding any startup preferences, BTW). This is no fix, but we can use it to work around the bug while waiting for a fix.
(Reporter)

Comment 5

9 years ago
Indeed it does - thanks!

Just like the old days, before these fancy "prefs". :)

Updated

9 years ago
Duplicate of this bug: 502431
Is this bug why I get the following error too?
{
Error: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: file:///.../components/nsBrowserContentHandler.js :: handle :: line 459"  data: no]
Source File: file:///.../components/nsBrowserContentHandler.js
Line: 466
}
Severity: normal → major
(Assignee)

Comment 8

9 years ago
Well, one causes the other, yes.

Updated

9 years ago
Attachment #386247 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 9

9 years ago
Pushed changeset 9c0a5a097fce to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Status: RESOLVED → VERIFIED
Target Milestone: --- → seamonkey2.0b1

Comment 10

9 years ago
Add fixed-seamonkey2.0 to make it go away from "unfixed blockers" query
Keywords: fixed-seamonkey2.0
You need to log in before you can comment on or make changes to this bug.