Random number of listed articles on Freetags search

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: Milos, Assigned: paulc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.11) Gecko/2009060309 Ubuntu/9.04 (jaunty) Firefox/3.0.11
Build Identifier: 

The nubmer of listed articles when a user search using a Freetags, isn`t constant. Every page in article listing has random number of displayed articles. Link to the search is in URL field of this bug. I`ve tried several searches using a different tag, and there is no a particular schema for number of displayed articles, so I think it`s random or it depends on something that I couldn`t figure out.

Reproducible: Always

Steps to Reproduce:
1. Open an article in https://support.mozilla.com/kb
2. Under the 'Tags in this article' in right menu, choose one
3. Look at the list of articles containing that tag and count the listed articles
4. Now go through 2nd, 3rd, 4th page and count the articles listed in them
Actual Results:  
The number of listed articles differs from one page to another.

Expected Results:  
All pages should have the same number of listed articles for a particular tag.

It looks like the number of listed articles goes from 2-9. If it`s possible, it would be good to increase it to, for example, 20 articles.
(Assignee)

Comment 1

9 years ago
Confirmed. David, Laura: is this worth fixing?
Assignee: nobody → paul.craciunoiu
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All

Comment 2

9 years ago
Yes. Agree about the severity though, but it is a stupid bug. One of those bugs that are probably already fixed in TikiWiki 3.0 though. Sylvie, is that correct?

Comment 3

9 years ago
NO - it is always the same problem - I already explained in another post: not all the lists are wysiwyg - the permissions are checked after the n elements are retrieved. We hope to fix this for 4 ....
But perhaps you have another problem in sumo as the tiki-browse_freetags.php has a lot of customization.

Comment 4

9 years ago
Thanks for the info Sylvie! 

So Paul, if you fix this bug, be sure to submit a patch to Tiki too (we'll formalize this procedure shortly, as we start the SUMO upgrade -> TikiWiki 3.0 process).
(Assignee)

Comment 5

9 years ago
This is not an easy fix. Articles are first queried and then filtered out if unaccessible to the respective user. Depending on what types of articles browse-freetags could list, the query would need to be modified accordingly, and it would depend on user permissions.

At first glance, (maybe only for SUMO) we could try having one query for logged-out users and one query for logged-in users.

Sadly, I think the fix is not immediate and probably not worth it.
(Reporter)

Comment 6

9 years ago
So, should we RESOLVED/WONTFIX?
(Reporter)

Comment 7

9 years ago
As per comment #5 , marking this one as wontfix.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.