NBC.com fails to play video on their full episode streaming application [caused by Adblock Filters]

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: felimz, Unassigned)

Tracking

({regression})

3.5 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729) AutoPager/0.5.2.2 (http://www.teesoft.info/)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729) AutoPager/0.5.2.2 (http://www.teesoft.info/)

This bug seems to be different than the previously reported bug (463826) about a similar problem. I have only tested the player in with Firefox 3.5 RC3 and IE8, and it only works on IE8. I want to make sure it's not a bug before reporting this to NBC as a case of Tech Evangelism.

Reproducible: Always

Steps to Reproduce:
1. Install Firefox 3.5 RC3
2. Download the latest Flash Player version at: http://get.adobe.com/flashplayer/otherversions/
3. Install Flash Player plug-in and restart Firefox
4. Go to provided URL at: http://www.tonightshowwithconanobrien.com//video/episodes/
5. At the bottom of the page, next to the "select episode" tab, choose the latest available episode.
6. The player will not play any video.
Actual Results:  
The player will not play any video.

Expected Results:  
The player should play video.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Comment 1

9 years ago
Tested on Windows Vista 32-bit with Firefox 3.0.11, and it works. Possible regression?
Keywords: regression, regressionwindow-wanted
First it has a browser detection problem and then "the clip is not available from my location". Tested on Windows Vista.
Felipe: This WFM using Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729). The video plays fine. Trying starting in Safe mode or disabling some of your extensions to see if they may be interfering.
It's known that adblock plus (or better one filterlist) can cause such videos to fail if the video trys to play an add-video before it starts with the real video.
(Reporter)

Comment 5

9 years ago
LOL. I had disabled all my extensions except AdBlock Plus. It needs confirmation that the ad video played before it can play the real video! I guess they're trying to force you into watching their ads. Thanks guys! Will disable AdBlock Plus for said website.
marking invalid (caused by adblock filter), thanks for the response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Component: General → Extension Compatibility
Keywords: regressionwindow-wanted
QA Contact: general → extension.compatibility
Summary: NBC.com fails to play video on their full episode streaming application → NBC.com fails to play video on their full episode streaming application [caused by Adblock Filters]
You need to log in before you can comment on or make changes to this bug.