aps.org - Unable to access Physical Review Letters website

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P3
minor
VERIFIED FIXED
18 years ago
3 years ago

People

(Reporter: Stephan C. Buchert, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

18 years ago
I have paid subscriptions to on-line journals (Physical Review Letters of the
American Physical Society and also others). A long time ago I entered their
service for the first time and had to enter a password that was provided by
them. Since this first time I always had access to the journals without password
and I have lost by now this password (Netscape lacking this nice new password
manager). However, now, with Mozilla, I cannot get access to the journal
anymore, with Netscape 4.75 I, of course, still can.

Assuming that it is problem with cookies, I have copied the contents of
/home/scb/.netscape/cookies into /home/scb/.mozilla/default/cookies.txt. This
"import" of cookies seems to have been successfull, since I can list in the
Mozilla Preferences many cookies from sites that I have visited previously using
Netscape. But it didn't solve the problem with the journal subscription...

I guess I should ask the guys of the American Physical Society what kind of
identification is actually used in their service, but I thought I report the
problem to you anyway. Is it possible that Mozilla doesn't send the cookies that
I have "imported" from Netscape?

Comment 1

18 years ago
Manual copying of your cookies file should have worked so I don't know what the 
problem is.  However, there is an automatic way to convert your old 4.x profile 
into a mozilla profile (cookies.txt included).  I'm not sure how you do that but 
the profile-migration group should know.  Reassigning to them.
Assignee: morse → dbragg
Component: Cookies → Profile Migration
QA Contact: tever → gbush

Comment 2

18 years ago
The proper invocation on Linux is "./mozilla -ProfileManager"

You should be prompted to import your old 4.x profile.  More choices are shown
with ./mozilla --help

Comment 3

18 years ago
I note that I am unable to sign into my account at www.amazon.com using their 
"secure server".  Could this be the problem the "American Physical Society" site 
rather than the cookie?

Comment 4

18 years ago
Do you have cookies enabled?  Are you accepting all cookies and not just cookies 
that get sent back to original server?

Comment 5

18 years ago
If you are running the mozilla build (rather than the commercial netscape 
build), have you installed PSM?

Comment 6

18 years ago
from reporter:

Thanks for your replies. I'm using a mozilla built and didn't install PSM
because I hadn't read about the Crypto stuff. This is probably the cause of
the problem. In case I still have problems after installing PSM I will submit
another bug report, ok?

resolve worksforme?

Comment 7

18 years ago
No, it's not works-for-me, but rather it's invalid.  It was due to the error on 
the part of the user of not having installed psm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 8

18 years ago
verify
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
Reporter is still having a problem and Q/A (sairuh) is able to reproduce it.  
Here is the sequence of steps for reproducing it, although it works fine when I 
try it.

1. Start with a fresh profile
2. Go to http://prl.aps.org/
3. Click on either of the two GO buttons
4. An error message appears

I have tried this on both a linux box and a win32 box and it works fine for me.  
What am I doing different than both the reporter and q/a?  For one thing I'm 
running debug builds whereas they are running optimized builds.

Anyhow, reporter now agrees that this is not a cookie problem since no cookies 
are involved for the steps listed above.  Maybe a networking problem?  dbragg, 
you should probably decide what component it is and reassign as necessary.

Changing summary line from "Importing cookies from netscape" to "Unable to 
access Physical Review Letters website"
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Importing cookies from netscape → Unable to access Physical Review Letters website

Comment 10

18 years ago
Your right Steve.  As the steps you listed show, this isn't a migration bug. It 
looks like you're the best candidate for this bug (sorry).  If it's not a cookie 
issue, then I don't know what it is.  But it ain't a migration problem.

Changing component to cookies and engineer to morse@netscape.com.
Assignee: dbragg → morse
Component: Profile Migration → Cookies

Comment 11

18 years ago
Well it ain't cookies so it's certainly not in my area.  I wouldn't mind fixing 
it if I could, but I can't fix it if I can't reproduce it.  I can't even get 
enough information to determine what area it's in.

So all I can do is reassign it to browser general and hope that the owner there 
can make a determination as to how to redirect this one.

It might help if the reporter can give some more details about the error message 
that he is getting.
Assignee: morse → asa
Component: Cookies → Browser-General
QA Contact: gbush → doronr

Comment 12

18 years ago
Stephan C. Buchert can you follow up with Physical Review Letters
 and see what kind of identification is actually used in their service?

Comment 13

18 years ago
I just received e-mail from the reporter containing the error message that he is 
getting.  Here it is:

Server Error

This server has encountered an internal error which prevents it from
fulfilling your request. The most likely cause is a
misconfiguration. Please ask the administrator to look for messages in
the server's error log.


Comment 14

18 years ago
Over to Evangelism, I suppose they're not letting us in because we're not
netscape or microsoft.
Assignee: asa → blakeross
Component: Browser-General → Evangelism
QA Contact: doronr → zach

Comment 15

18 years ago
Assigning to self. Will write the email to them soon. Confirming
Assignee: blakeross → zach
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 16

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Comment 17

17 years ago
taking
Assignee: zach → bclary
Summary: Unable to access Physical Review Letters website → aps.org - Unable to access Physical Review Letters website
(Assignee)

Comment 18

17 years ago
From a comment from Stephan, it appears that Phys Rev Letters now lets us in.
Stephan, please reopen this bug or send me email if you continue to have
problems with the site.


Aaahhhh, the good old days... Phys Rev D could always put me to sleep. ;-)
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED

Comment 19

17 years ago
Verified
2002030908/WinXP
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.