Closed Bug 501281 Opened 11 years ago Closed 10 years ago

:hover CSS selector doesn't work without E prefix

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 197686

People

(Reporter: netdur, Unassigned)

Details

Attachments

(1 file)

219 bytes, text/html
Details
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090401 Ubuntu/9.04 (jaunty) Shiretoko/3.5b4pre
Build Identifier: 

doing .class:hover has no effect, this CSS selector must have E prefix to work

Reproducible: Always
Attached file hover.html
working example
This is a known quirks mode behavior:
https://developer.mozilla.org/en/Mozilla%27s_Quirks_Mode

Is it not present in other browsers anymore?
epiphany using gecko has the same problem, epiphany using webkit works as expected
(In reply to comment #2)
> This is a known quirks mode behavior:
> https://developer.mozilla.org/en/Mozilla%27s_Quirks_Mode
> 
> Is it not present in other browsers anymore?

Opera 10b and WebKit/Safari4 do not have this Quirk (anymore). IE 8 mimics IE6 & 7 (and Gecko) in quirks mode.
Duplicate of this bug: 533653
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 197686
You need to log in before you can comment on or make changes to this bug.