If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Archive Button sends messages to nowhere on items in a global search on IMAP inbox

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: bugzilla.mozilla.org, Unassigned)

Tracking

({qawanted})

Trunk
x86
Windows XP
qawanted
Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090627 Lightning/1.0pre Shredder/3.0b3pre

I played with global search. I got a search result of 4 messages. I selected all of them and then hit the "Archive" button in the mail header. 

The "Archives" and subfolders "2008" and "2009" got created. One message got moved to 2008. Three other messages should have been moved to 2009 (and did get moved according to Activity Manager) but do not show up in 2009. They are no longer in the original location but I could not find them anywhere else.

As a last resort I tried "Undo" four times and got all archived messages back to their original location. Archive Manager now shows "1 indexed message" in the original folder. This seems to indicate that the three others never left this original folder?

Thanks to undo I have my messages back.

Error console showed nothing during the whole operation

Uploading screenshot ...

Reproducible: Didn't try
(Reporter)

Comment 1

8 years ago
Created attachment 385991 [details]
screenshot describing the situation

The red marked activities are the Archiving of the four messages. the green marked activities happened during or after the "Undo" actions
Flags: blocking-thunderbird3?
Version: unspecified → Trunk

Comment 2

8 years ago
IMAP or POP3? If IMAP, could you generate a protocol log?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #2)
> IMAP or POP3? If IMAP, could you generate a protocol log?

Instructions on how to generate such logs are available at https://wiki.mozilla.org/Thunderbird:Testing.
Keywords: qawanted

Comment 4

8 years ago
A protocol log is only useful in this case if it's IMAP.
I played around with this briefly and I can't reproduce it, therefore moving back to unconfirmed as we need more information e.g. the requested logs, more information about the reporter's settings etc.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: blocking-thunderbird3? → blocking-thunderbird3-
(Reporter)

Comment 6

8 years ago
hi and sorry for not getting back earlier.

I'm at TB3 beta3 meanwhile and cannot reproduce the issue. Whatever it was, it did not happen again.

marking as closed invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.