If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Case sensitive problem with Password manager blocks input fields

RESOLVED DUPLICATE of bug 499649

Status

()

Toolkit
Password Manager
--
major
RESOLVED DUPLICATE of bug 499649
8 years ago
8 years ago

People

(Reporter: sananaman, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1) Gecko/20090616 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1) Gecko/20090616 Firefox/3.5

When a username "NaviGator" is saved in the password manager. It is not possible to save another username "navigator" or any other combination.
This worked fine with all the other FireFox versions, but in 3.5 this bug is introduced.


Reproducible: Always

Steps to Reproduce:
1. Enter inside a login/password field "NaviGator" (without quotes).
2. Click submit of the form field.
3. Firefox asks to save password, just press save.
4. Make sure you are logged out again.
5. Now try to login with "navigator" (without quotes).
6. Now you see you are forced to use "NaviGator", whatever you try.

Actual Results:  
You cannot login anymore because FireFox is forcing you to use the first stored login and pass with the given case sensitivity. The new given name can't be saved in the password manager.


Expected Results:  
FireFox user name is "Case Sensitive" and can be stored.
For example we would like to store:
- NaviGator
- Navigator
- NaViGaToR
- navigatoR

All as different users. Because usernames can be case sensitive in some systems.

Idea: make it optional in the password manager (checkbox).


We are using FireFox 3.5 at Wolters Kluwer for testing our portals. With this bug FireFox 3.5 becomes worthless and we have to move on using alternatives.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.5 Branch

Updated

8 years ago
Component: Preferences → Password Manager
Product: Firefox → Toolkit
QA Contact: preferences → password.manager
Version: 3.5 Branch → 1.9.1 Branch

Comment 1

8 years ago
Possibly a dupe of bug 499649 or bug 447788 broke this?  Here is a query of bugs in the password manager that have "case" or "capital" in the summaries... http://tinyurl.com/nj596g

Do you think users will have multiple logins to the same site that differ in case?
Whiteboard: [dupeme]
(Reporter)

Comment 2

8 years ago
First of all I didn't know the Password manager was part of the "Toolkit". Thanks for pointing it out. I also saw that there is another bug 499649 that describes the same bug actually.
https://bugzilla.mozilla.org/show_bug.cgi?id=499649

To answer your question. In our firm yess we use case sensitive logins and the test team is using this as well. See above discription.

Once a string is saved in PW manager and you try to login with a same name but then case sensitive then it forces you to login with the stored name. There is no other way to change it until you remove it from PW manager.

Try:
http://www.inluppar.com/logintest/
(Reporter)

Comment 3

8 years ago
Duplicate...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499649
You need to log in before you can comment on or make changes to this bug.