Status

()

Core
SVG
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Hendrik M Halkow, Unassigned)

Tracking

({regression})

1.9.1 Branch
regression
Points:
---

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

The SVG Performance of Firefox 3.5 is pretty slow. The XHTML document on http://warsimulator.appspot.com/static/warsim.xhtml
is running quite good on Firefox 3.0.11, Safari 4 and Opera 10b. However, the performance on 3.5 is reduced dramatically.

Reproducible: Always

Steps to Reproduce:
1. Go to http://warsimulator.appspot.com/static/warsim.xhtml 
2. Hover over the cells. The cell you are hovering over will be highlighted.
3. Click on a cell to select it and play around with the orange buttons on the top right. They will change the height and the terrain (The buttons on the top left don't have any function yet).
Actual Results:  
When hovering over the cells, the window sometimes stalls for a few second.
When clicking the top left buttons, it takes significant time to update the view.

Expected Results:  
It should work at least as fast as in 3.0.11. The latest releases of Opera and Safari are the reference how fast this can work.
Component: General → SVG
Product: Firefox → Core
QA Contact: general → general
Regression range seems to be
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1949346e6006&tochange=6e39da3e3e20
I tested the top orange cell: increaseHeight. Clicked 20x per 10 seconds and a "bad" build was not yet finished after 10 seconds.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → 1.9.1 Branch
Almost certainly bug 455984. I guess the first thing to do is to reduce the testcase.
The testcase uses opacity all over. Restoring the opacity optimisation fixes this.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Depends on: 523481
Resolution: --- → FIXED
status1.9.2: --- → beta1-fixed
You need to log in before you can comment on or make changes to this bug.