Trunk build scrolling more area (scrolling faster) than it previously has

VERIFIED FIXED

Status

()

Core
Widget: Win32
VERIFIED FIXED
9 years ago
7 years ago

People

(Reporter: u88484, Assigned: jimm)

Tracking

({regression})

Trunk
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Starting with today's trunk build (20090630), pages scroll further/faster than they did in the 20090629 build.
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
Bug 493037 looks like a good candidate for causing this.
Blocks: 493037
(Reporter)

Updated

9 years ago
No longer blocks: 493037
Depends on: 493037

Comment 2

9 years ago
Another symptom: If mouse wheel scrolling is set to a page at a time, the browser page will move to the top or bottom of the page. I have to use the scroll bar to move to anywhere other than the top or bottom of the page if the page is more that two screen heights long.
Duplicate of this bug: 501390

Comment 4

9 years ago
This also appears on Windows 7.
(Assignee)

Comment 5

9 years ago
Created attachment 386052 [details] [diff] [review]
wheel fix

My refactor patch in 487245 split the wheel scroll event handling out into an
event handler, which introduced a bug where aRetValue was not set correctly. 

This patch addresses that and also adds some commenting to OnWheelScroll to
clearly explain what the handler does.
Assignee: nobody → jmathies
(Assignee)

Updated

9 years ago
Depends on: 487245
No longer depends on: 493037

Comment 6

9 years ago
This also appears on Windows XP - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090630 Minefield/3.6a1pre (.NET CLR 3.5.21022). This is extremely annoying. The middle-click-scroll speed is the same as it has always been, though.

Updated

9 years ago
Attachment #386052 - Flags: review+
(Assignee)

Comment 7

9 years ago
http://hg.mozilla.org/mozilla-central/rev/9b3b3169bf08
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified Fixed using hourly build:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090630 Minefield/3.6a1pre Firefox/3.0.11 ID:20090630122827

changeset:
http://hg.mozilla.org/mozilla-central/rev/0ebf4f99895e
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: General → Widget: Win32
QA Contact: general → win32
A unittest for this would be great. :)
(Assignee)

Comment 10

9 years ago
(In reply to comment #9)
> A unittest for this would be great. :)

I was wondering the same thing, why didn't a unit test pick this up? Maybe it's hard to do as mouse drivers are involved in defining scroll speeds.

Comment 11

9 years ago
This still seems to be happening in 3.6 alpha 1.  I'm running Windows 7.

Comment 12

9 years ago
(In reply to comment #11)
> This still seems to be happening in 3.6 alpha 1.  I'm running Windows 7.

What you see is not this bug, but an intentional change in the scrolling behavior. See http://margaret.mit.edu/2009/08/making-firefox-feel-faster/ for more details (bug 462809).
You need to log in before you can comment on or make changes to this bug.