Upgrade from Firefox 3.0.11 to 3.5 causes Google Toolbar to stop working

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: speed1084, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5 GTB5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5 GTB5 (.NET CLR 3.5.30729)

On upgrading FF from 3.0.11 to 3.5, Google Toolbar (version 5.0.20090324) stops functioning. It looks like the toolbar exists, but toolbar buttons no longer appear, and toolbar settings does not allow customization (adding buttons, changing layout, generation of custom search)

Reproducible: Always

Steps to Reproduce:
Steps to reproduce:
pre-requisites: FF 3.0.11 needs to be installed on Windows PC, and Google Toolbar 5.0.20090324 needs to be installed for Firefox)
1. Launch Firefox 3.0.11, select Help > Check for updates > Update.
2. User gets prompted to install FF 3.5, proceed to complete installation.
3. Choose to restart Firefox to complete upgrade.
Actual Results:  
Firefox upgrade installer checks compatibility of existing extensions, but does not report any incompatibility with Google Toolbar.
Upon launch of Firefox 3.5:
1. Toolbar exists, but toolbar buttons no longer appear (only Google button remains)
2. Toolbar settings does not allow customization (adding buttons, changing layout, generation of custom search).

Expected Results:  
Firefox upgrades sucessfully to 3.5 and Google Toolbar should work as before upgrade (since extension incompatibility was not reported).

1. Toolbar was restored to normal functionality, by unistalling and re-installing the Google Toolbar extension.

However, windows reports an "uninstall" error.
Also Autofill data from toolbar does not get retained, but previously existing toolbar buttons are restored.

2. This was observed on 2 operating systems:
a)Windows Vista SP 1,Intel Core 2 Duo, 2Ghz, 4GB, 32-bit machine.
b)Windows XP, SP3, Intel 2Ghz, 1.5 GB 32-bit machine.
Please report to Google. This is not our problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Version: unspecified → 3.5 Branch
You need to log in before you can comment on or make changes to this bug.