Problems playing short Vorbis sounds

VERIFIED FIXED

Status

()

--
minor
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: u287251, Assigned: cpearce)

Tracking

1.9.2 Branch
Points:
---

Firefox Tracking Flags

(status1.9.2 beta2-fixed, status1.9.1 ?)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

Two shrot sounds -- less than one second -- won't play (OGG), or won't sound like the originals (WAV), as if some reverb effect was added to the rendering of the sounds.

Reproducible: Always

Steps to Reproduce:
1. Go to link above, I made a test case for the problems reported here
2. Play the OGG files
3. Play the WAV files
Actual Results:  
2. OGG files: No sound
3. WAV files: Sounds are unlike the original (Download and play with a media player.) There seems to be some reverb effect or something.

Expected Results:  
2. OGG files: Sounds properly heard
3. WAV files: Sounds properly rendered as in the originals

Updated

9 years ago
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: unspecified → 1.9.1 Branch

Comment 1

9 years ago
Confirming the first issue of the short sounds not playing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
It seems like this is a problem with the files.  Playing the mp3 files with mpg123 and the wave files with play, they sound quite different.  They also have different durations (the mp3s are longer: 650ms vs 270ms for the first, and 620ms vs 240ms for the second).  The ogg files play back as silence in ogg123 and QuickTime with XiphQT installed.
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
> It seems like this is a problem with the files.  Playing the mp3 files with
> mpg123 and the wave files with play, they sound quite different.  They also
> have different durations (the mp3s are longer: 650ms vs 270ms for the first,
> and 620ms vs 240ms for the second).  The ogg files play back as silence in
> ogg123 and QuickTime with XiphQT installed.

I hadn't realized the preview of the sound effects at The Freesound Project for these files were MP3s (I actually made a conversion to MP3 on my side, since WAV files were served at d/l time.) I thought they were playing the WAV files as submitted by the author. So the second issue about WAV files not properly rendered is a false alarm, needs to be dismissed.

To add to the first part, Windows Media Player reports that "CoreVorbis Audio Decoder" is used to play the OGG files.
Using oggdec on the files results in Wave files that sound the same as the Wave files linked in the testcase, so the Vorbis files are valid.

It looks like we don't get any frames from liboggplay.  We call NextFrame four times, and oggplay_buffer_retrieve_next returns null every time.
Summary: Problems playing short sounds → Problems playing short Vorbis sounds
It's likely that this'll be fixed when bug 512328 lands.
(Assignee)

Updated

9 years ago
Depends on: 512328

Comment 6

9 years ago
This sounds like a duplicate of bug 501708. That one is fixed.
So please confirm and close this one.

Updated

9 years ago
Duplicate of this bug: 507671

Comment 8

9 years ago
This is not a duplicate of "Short OGG audio files stutter and appear to start playing twice when manually played". That's fixed in this morning's nightly.

A better description for this bug might be "Very short Vorbis files do not play at all", which is still a problem in the same nightly.

My example file is http://dingoskidneys.com/~dholth/clock/digits/1.ogg

Plays okay in Chrome or VLC.
(Assignee)

Comment 9

9 years ago
Not fixed by bug 512328 checkin. Looks like bug 516323.

R. Hill / Daniel Holth: you can work around this bug by serving an X-Content-Duration header (see https://developer.mozilla.org/en/Configuring_servers_for_Ogg_media for details), which will allow you to play the file at least.
Depends on: 516323
No longer depends on: 512328
I think the patch for bug 520493 fixed this.
Yep.  Specifically, it was fixed by the overhang handling change in that patch.
Assignee: nobody → chris
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 520493
No longer depends on: 516323
Resolution: --- → FIXED
Yes, the patch for bug 520493 does appear to have fixed the problem. However, that patch was not applied to the 1.9.1 branch, because it was fixing a regression that occurred after Firefox 3.5, meaning it didn't occur in 3.5 and was only fixed for the 1.9.2 branch (Firefox 3.6).

This bug (bug 501545) actually occurs in 3.5, so I think that part of that patch (whichever part it is) should be backported to the 1.9.1 branch. As such, I'm reopening this bug and setting the status1.9.1=? flag. (I'm also carrying over the status1.9.2=beta2-fixed flag from the other bug, just for the sake of completeness.)

More examples of OGG sounds that don't play (in Firefox 3.5.7) can be found here:
http://en.wikipedia.org/wiki/Dual-tone_multi-frequency#Keypad
Severity: normal → minor
Status: RESOLVED → REOPENED
status1.9.1: --- → ?
status1.9.2: --- → beta2-fixed
OS: Windows XP → All
Hardware: x86 → All
Resolution: FIXED → ---
I don't think this bug is critical enough to warrant backporting the fix to 1.9.1, especially when 1.9.2 is so close to release.
(Assignee)

Comment 14

8 years ago
Fixed on 3.6 and trunk, and we only backport security & stability fixes, so re-resolving fixed.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
Version: 1.9.1 Branch → 1.9.2 Branch
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.