Hangs when page has many controls

RESOLVED DUPLICATE of bug 477564

Status

()

--
minor
RESOLVED DUPLICATE of bug 477564
9 years ago
9 years ago

People

(Reporter: blessonrajan, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

When you open a page with so many form controls (tens and hundreds, or more), FF response becomes sluggish. Sometimes entering data into text field does not appear instantly, sometimes page scrollbars go unresponsive etc.

Reproducible: Always

Steps to Reproduce:
1. Open a page with many controls. (create a page like below)
<script language="javascript">
	for(i=0; i<500; i++){
		document.write('<input type="radio"/><br>');
	}
</script>

2. Click on the vertical scrollbar and drag from top to bottom quickly several times. In about 10 moves, FF usually goes unresponsive.

3. Once it recovers, click and a few controls, or enter values into a few control. FF again goes unresponsive.
Actual Results:  
FF goes unresponsive for several seconds (depending upon the number of controls)

Expected Results:  
FF should be responsive all the time

Comment 1

9 years ago
See comment 0 of bug 477564 for a workaround
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477564
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
You need to log in before you can comment on or make changes to this bug.