dragging+hovering over the search bar should cause the list of engines to popup/open

NEW
Unassigned

Status

()

P3
enhancement
9 years ago
a year ago

People

(Reporter: rd1381, Unassigned)

Tracking

3.5 Branch
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.0) Gecko/20090623 SUSE/3.5.0-2.1 Firefox/3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.0) Gecko/20090623 SUSE/3.5.0-2.1 Firefox/3.5

i have many search engines added to search bar and in firefox 3 i could drag a text to search bar and hold it over search engine icon and i would list the search engine and i would release the mouse over desired search engine and it would search using that engine.
not anymore in firefox3.5 
it doesnt load the list of my search bars :(

Reproducible: Always



Expected Results:  
list the search engines

Comment 1

9 years ago
I'm not able to reproduce your expected behavior in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.11) Gecko/2009060214 Firefox/3.0.11
Me neither. Dragging text over the search icon dropdown doesn't open the list of search engines for me with Firefox 3.0.x. Reporter, can you please be more specific?
Summary: draging to serarch bar doesnt list the search engines → dragging to serarch bar does not list the search engines
Version: unspecified → 3.5 Branch

Comment 3

9 years ago
Kinda sounds like they were using https://addons.mozilla.org/en-US/firefox/addon/3696
(Reporter)

Comment 4

9 years ago
in firefox 3.0.X when i dragged a text to search engine bar and hold it over icon of search engine it showed a dropdown list of search engines and droping the text onto one of them opened search query in that search engine.

and no i am not using https://addons.mozilla.org/en-US/firefox/addon/3696

i was using search engine organizer addon but it is disabled in 3.5
So can you please run Firefox 3.0.x in Safe Mode (http://support.mozilla.com/kb/Safe+Mode) to check if this functionality is still available? I suspect it. Even when it is not the suspected add-on another one could have been added this feature. Ryan, this isn't a built-in feature, right?
We don't have any code that handles this specifically, so unless it's built-in to the dropdown widget, I don't think we've ever had this feature. We probably should, though!
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Summary: dragging to serarch bar does not list the search engines → dragging+hovering over the search bar should cause the list of engines to popup/open
(Reporter)

Comment 7

9 years ago
sorry
you were right
its a feature of organize search engine extension
but as you said
"I don't think we've ever had this feature. We probably
should, though!"
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

9 years ago
Status: REOPENED → NEW
That looks really sweet and would avoid manual search engines selection.
Flags: wanted-firefox3.6?

Updated

9 years ago
Duplicate of this bug: 502286

Comment 10

9 years ago
Argh... been thinking about this one since 2.0.  Finally got around to posting it, only to find out somebody else beat me to it by two days!!  \-)

Comment 11

9 years ago
If this bug is being considered in order to improve usability out-of-the-box, then I'd suggest to take a look as well at:

https://bugzilla.mozilla.org/show_bug.cgi?id=216667 and 
https://bugzilla.mozilla.org/show_bug.cgi?id=492544 .

Comment 12

9 years ago
Please don't use Bugzilla for advocacy the bugs are unrelated to this issue. https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Updated

9 years ago
Status: REOPENED → NEW

Updated

9 years ago
Priority: -- → P3
Target Milestone: --- → Future
Flags: wanted-firefox3.6?
You need to log in before you can comment on or make changes to this bug.