[wishlish] Warn when leaving form with unsaved data

RESOLVED DUPLICATE of bug 48333

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 48333
9 years ago
9 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.11) Gecko/2009061118 Fedora/3.0.11-1.fc10 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.11) Gecko/2009061118 Fedora/3.0.11-1.fc10 Firefox/3.0.11

Other browsers, such as Konqueror, warn when leaving a form containing unsaved data, and give an opportunity to cancel that "leaving" operation (avoiding to lose that data).

It would be useful to pop up such a warning when:
1. Closing the tab (or browser) containing the form (done by Konqueror)
2. Navigating away from the form using a link (not yet done by Konqueror)


Reproducible: Always

Steps to Reproduce:
1. Go to any page with a form
2. Fill in some data
3. Close tab
Actual Results:  
No warning

Expected Results:  
A warning that the form contains unsaved data, asking are you sure you want to leave it.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 48333
You need to log in before you can comment on or make changes to this bug.