Developer tools won't load

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Developer Pages
--
critical
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: Wladimir Palant, Assigned: clouserw)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
If I try to open https://addons.mozilla.org/en-US/developers or https://addons.mozilla.org/en-US/firefox/user/346 the page just keeps loading - it never finishes. Pages of other users load fine, https://addons.mozilla.org/en-US/firefox/user/346 shows up blank even when I'm not logged in however. So I guess the problem is specifically with my account. I was able to upload the new Element Hiding Helper release by skipping directly to https://addons.mozilla.org/en-US/developers/versions/4364/.
(Assignee)

Updated

9 years ago
Assignee: nobody → clouserw
(Assignee)

Comment 1

9 years ago
Can you load /developers on preview.amo?  This may be a memory issue that we already sorted out
(Reporter)

Comment 2

9 years ago
Yes, it takes a while but it loads.
I would like to say it was fixed in bug 497743, but that did not touch the developers controller. This may an additional page that pulls in all collections. :(
PS: I come to that assumption from the fact that I can load the dev controller without problems, as I, unlike Wladimir, do not have hugely popular add-ons ;)
(Assignee)

Comment 5

9 years ago
I can reproduce this on my dev copy with the old code and last nights database dump but it looks fixed in the new (and preview is working).

It would be nice to patch this locally on production if we get time.
(Reporter)

Comment 6

9 years ago
Seeing that this issue still occurs, when is the fix supposed to be merged to production?
(Reporter)

Comment 7

9 years ago
This is probably also preventing users from reviewing Adblock Plus:

> I have been trying to leave a review for the Adblock Plus addon. It wouldn't save my review.
> 
> I noticed that the last review left was on July 2. Prior to that date, several reviews were left every day, but during the last 27 days not one review has been left.
> 
> Is there a technical problem that is not letting people post reviews for this addon?
> 
> When I click on "Post Review", the site just keeps loading forever. It is also impossible to go to "detailed review". When you click on it, it just tries to load and never goes to the "detailed review" page.
(Assignee)

Comment 8

9 years ago
(In reply to comment #6)
> Seeing that this issue still occurs, when is the fix supposed to be merged to
> production?

We're pushing 5.0.8 on Thursday.  If you can wait until then I'd like to.

(In reply to comment #7)
> This is probably also preventing users from reviewing Adblock Plus:
> 
> > I have been trying to leave a review for the Adblock Plus addon. It wouldn't save my review.
> > 
> > I noticed that the last review left was on July 2. Prior to that date, several reviews were left every day, but during the last 27 days not one review has been left.
> > 
> > Is there a technical problem that is not letting people post reviews for this addon?
> > 
> > When I click on "Post Review", the site just keeps loading forever. It is also impossible to go to "detailed review". When you click on it, it just tries to load and never goes to the "detailed review" page.

This fix was pushed yesterday.  I just successfully added a review and I see 3 others from today as well.
You can bypass the dashboard by going to:

https://addons.mozilla.org/en-US/developers/addon/edit/{addon id}
(Reporter)

Comment 10

9 years ago
Wil, thanks for the info. Justin - yes, bypassing the dashboard like that is what I have been doing the last month.
(Reporter)

Comment 11

9 years ago
(In reply to comment #8)
> This fix was pushed yesterday.  I just successfully added a review and I see 3
> others from today as well.

Yes - but it seems that I will have to wait until Thursday until I can reply to those reviews. https://addons.mozilla.org/en-US/firefox/reviews/reply/151677 never loads.
(Reporter)

Comment 12

9 years ago
=> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Resolution: WORKSFORME → FIXED
Verified; I can now access https://addons.mozilla.org/en-US/firefox/reviews/reply/151677 and all of the URLs in comment 0.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.