Search bar contents disappear after running Glary Utilities

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: gwestbound, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

Search bar contents disappear. Have to put in Firefox back up to restore them. That's all the information I have. I am going back to the previous version.

Reproducible: Sometimes
Do you mean that you had to switch back to Firefox 3.0 to see the search options?
Component: Page Info → Search
QA Contact: page.info → search

Comment 2

9 years ago
Myabe only the search box (upper right hand corner) wouldn't show. That might be fixed when you undo the customization of the toolbar (or reset it completely)

http://support.mozilla.com/en-US/kb/How+to+customize+the+toolbar
http://support.mozilla.com/en-US/kb/Back+and+forward+or+other+toolbar+buttons+are+missing
Version: unspecified → 3.5 Branch
(Reporter)

Comment 3

9 years ago
Thanks for your reply.

I discovered what is really happening. I do computer backups with Acronis vll. Fx 3.5 loses its Searchbar contents when it is backed up. Fortunately I also back up Fx with Mozbackup, so I have been able to restore it.

I tried to uninstall Fx 3.5 and reinstall Fx 3.0.11, but the previous version will not install correctly. Don't know why. I'm still with 3.5.

I have been using Fx since the Phoenix/Firebird days without problems. It's a terrific browser. Hope you can fix this. It's a royal pain in the a$$!

Regards,

GW
(Reporter)

Comment 4

9 years ago
See my earlier reply.

I have no toolbar customizations.

The search bar still shows. It's the search bar contents that disappear.

Regards,

GW
(Reporter)

Comment 5

9 years ago
See reply above. I couldn't get Fx 3.0.11 to install correctly. Don't know why.

Regards,

GW

Comment 6

9 years ago
(In reply to comment #4)
> See my earlier reply.
> 
> I have no toolbar customizations.
> 
> The search bar still shows. It's the search bar contents that disappear.
> 
> Regards,
> 
> GW

I think you mean the location bar (or URL bar), which is where the address of the website is visible. It's the longest textfield in the middle of the toolbar. Searching is done in the smaller textfield on the right, with the magnifying glass (and probably the Google icon on the left, or another search engine).

If it's the location bar, then I think that your backup process is messing up with the places.sqlite file, where the bookmarks and history is stored. This database file is opened in exclusive mode, so no external process can access it while Firefox is still open. Maybe that creates problems in your backup application ?
(Reporter)

Comment 7

9 years ago
Created attachment 386503 [details]
Searchbar screen shot
(Reporter)

Comment 8

9 years ago
I beleive it is called the Searchbar. See the attachment for a screen shot. It loses its contents. The drop down menu goes blank.

Acronis V.11, my backup, program has not caused this or any other problem with previous Fx versions.

GW
So when does the content disappear for you? After a restart? After a backup was running? Please give us a bit more information.
(Reporter)

Comment 10

9 years ago
Thanks for your effort.

Acronis kicks out the Searchbar contents. Mozbackup restores them. Been using these applications for years without a hitch, until Fx 3.5.

Don't know what more I can say. The workaround I have been using is to restore Fx from a Mozbackup.

Regards,

GW

Comment 11

9 years ago
The content comes from the search.json file in your profile
(Reporter)

Comment 12

9 years ago
Created attachment 386505 [details]
search.json file
(Reporter)

Comment 13

9 years ago
I am attaching the search.json file. I don't know what to look for in it.
Gardiner, please answer my last question in detail. A half is missing. What do you mean with contents? The search term? The search history? Please give detailed steps what you are doing in Firefox to reach this state.
(Reporter)

Comment 15

9 years ago
Thank your for your letter.

I filed two bug reports.

Bug 501631 deals with the Searchbar contents disappearing after a backup with Acronic V.11 and an FX restart.

Bug 501633 deals with half the Add-ons ceasing functioning after a backup with Acronic V.11 and an FX restart.

I beleive a review of the correspondance will confirm they have been inadvertently comingled. This is creating confusion.

I think I have answered all the questions posed to me, but in the event I have overlooked one or my unswers have been unclear I will be happy to continue.

Best regards.

GW
(Reporter)

Comment 16

9 years ago
I now have reason to believe Glary Utilities, which I run before backing up, is the culprit that is killing the searchbar contents. There were no ill-effects with previous Firefox versions.
So please disable/uninstall the Glary Utilities to check if they are the cause of your problem. I will have other questions afterward. Thanks.
(Reporter)

Comment 18

9 years ago
Glary Utilities seems to be the cuplprit for both Bug 501631 and Bug 501633. I uninstalled it and did every test I could think of with no ill-effect on FX 3.5. The Fx 3.5 Searchbar and Add-ons remain intact and functioning.

I substituted CCleaner for Glary. CCcleaner does much the same thing and has no deleterious effect on FX 3.5
Thanks for your time to track down this issue. Due to the fault is by an external program it makes this bug invalid. If you want you can get in contact with the developers and mention your problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Summary: Search bar contents disappear. Have to put in Firefox back up to restore them. → Search bar contents disappear after running Glary Utilities
Duplicate of this bug: 501633
You need to log in before you can comment on or make changes to this bug.