Some but not all passwords are lost, after update to FF 3.5 from 3.0.11

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Renè Glanzer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-06-04], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1) Gecko/20090624 Firefox/3.5

After the update to FF 3.5 some of my saved passwords are lost. The strange behavior is, that there are still lots of pwd's saved but not all. I found no pattern why some are lost and others not.
In FF 3.0.11 a master password was set which also works in 3.5.
Maybe this fact helps for the search


Reproducible: Sometimes

Steps to Reproduce:
1.Open a page where i know FF 3.0.11 saved the pwd Example for me: https://portal.ascio.com/Logon.aspx
2.Click in the login field an choose the correct login for this page
3.The pwd should be filled out by FF3.5 which isn't happening.
Actual Results:  
The pwd field leaves blank. Also when I open the Password Manager and search for the desired URL no entry is found.

Expected Results:  
The saved pwd as of FF3.0.11 should be filled in the corresponding field

Comment 1

9 years ago
I've had this bug too. It's particularly annoying because when I restored my passwords using mozbackup it didn't work and it's also triggered the bug where the search widget ceases to work, forcing me to delete formhistory.sqlite as well.
Component: Security → Password Manager
Product: Firefox → Toolkit
QA Contact: firefox → password.manager
Did you previously use a Firefox 3.5 beta, and then switch back to 3.0?

Passwords are only imported from the Firefox 3.0 file (signons3.txt) once, so you may have an old signons.sqlite. You can delete the signons.sqlite in your profile to force reimporting from signons3.txt.
(Reporter)

Comment 3

9 years ago
No I didn't use a beta of FF3.5. I was switched per auto-update to FF 3.5 directly from the FF 3.0.11 version.

But I'll give it a try. I see that i have a "signons2.txt" and a "signons3.txt" maybe this could be a point of problem?
Nevertheless I try to delete the signons.sqlite file, or better to say i move i to a backup dir :-)
(Reporter)

Comment 4

9 years ago
Hi,

to delete the signons.sqlite file really helped. Now the new generated file has a size of 458KB whereas the old one only had 183KB.
Maybe at the creation process FF3.5 had a problem the first time?
For now, this resolved my problem -> THANKS

Comment 5

8 years ago
Please update if you are still experiencing this. If it works for you, Please close it as Resolved -> Worksforme.
Whiteboard: [closeme 2010-06-04]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.