If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

playing audio streams using the <audio> tag sounds bad

NEW
Unassigned

Status

Fennec Graveyard
General
8 years ago
7 years ago

People

(Reporter: Uwe Kaminski, Unassigned)

Tracking

Trunk
Other
Linux
Bug Flags:
wanted-fennec1.0 +

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: fennec nightly build 20090630 on Maemo 4.3.1 (5-2008.43-7)

I used a N800 and I was connected on a wifi network. There were no other applications open. I was able to listen to the sound but there were a lot of gaps. All in all listing to the stream was inaudibly.

On my desktop the stream works nice.  

Reproducible: Always

Steps to Reproduce:
1. start fennec
2. got to: http://alpha.libre.fm/listen/?tag=jazz
3. Start playing a song
Actual Results:  
A lot of small interruptions make listing to the stream inaudibly.

Expected Results:  
Sound without interruption.

Fennec seems to need to much ressources from the whole system to play streams.
Flags: wanted-fennec1.0+
This is another bug that needs to be identified as supported or not.

Comment 2

8 years ago
No problems here. Maybe your wifi was the culprit?
This works for me as well on build:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.5pre) Gecko/20100419 Namoroka/3.6.5pre Fennec/1.1a2pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
I get "Streaming provided by Jamendo is currently broken, due to a hardware failure.", so this is currently impossible to verify.
Still broken.
How about the example here: http://hacks.mozilla.org/2009/06/audio-player-html5/
Ok, thanks, there is a link on that page to http://hyper-metrix.com/misc/jai/ .
When I try to listen audio on that page, I indeed get a lot of interruptions, which basically makes the music unbearable to hear.
This is tested on a 1.9.3 trunk build from yesterday on the n900.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
I guess this is a ogg decoder problem then?
Maybe this will help? http://hacks.mozilla.org/2010/04/theora-on-n900/
Is this fixed now that the Tremor Ogg decoder has landed?
You need to log in before you can comment on or make changes to this bug.