Crash when scrolling down the page [@ libqtcurve.so@0x2f4e1 - moz_gtk_widget_paint - ThemeRenderer::NativeDraw]

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
9 years ago
2 years ago

People

(Reporter: uomonero84, Unassigned)

Tracking

({crash})

1.9.1 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux; it-IT) AppleWebKit/527+ (KHTML, like Gecko, Safari/419.3)  Arora/0.7.1 (Change: 931 d4cb764)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9.1.0) Gecko/20090623 SUSE/3.5.0-2.1 Firefox/3.5

When I scroll down the page, firefox may crash.
I've experienced this problem with a number of different page, also in the official release note page.

The error output from shell:
/usr/bin/firefox: line 126:  4748 Segmentation fault      $MOZ_PROGRAM "$@"


Reproducible: Sometimes

Steps to Reproduce:
1. Open Firefox
2. go to http://www.mozilla-europe.org/it/firefox/3.5/releasenotes/
3. Scroll down the page with mouse or arrow
Actual Results:  
crash!, then error like this:
/usr/bin/firefox: line 126:  4889 Segmentation fault      $MOZ_PROGRAM "$@"
or this
/usr/bin/firefox: line 126:  4861 Segmentation fault      $MOZ_PROGRAM "$@"

Expected Results:  
don't crash...

I use Opensuse 11.1 on NVIDIA 9600m GT
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch

Comment 1

9 years ago
Can you reproduce in safe mode and could you please attach the crash id from about:Crashes?
Keywords: crash
Whiteboard: crashidneeded
(Reporter)

Comment 2

9 years ago
I've reproduced in safe mode, but when I type "about:Crashes" in the address bar, I've an "invalid address" error dialog.

Comment 3

9 years ago
(In reply to comment #2)
> I've reproduced in safe mode, but when I type "about:Crashes" in the address
> bar, I've an "invalid address" error dialog.

Sorry, I seen the mistype as submitting.  it should be about:crashes in all lowercase
(Reporter)

Comment 4

9 years ago
I've tried in all lowercase too, but I've an "invalid address" error dialog
(Reporter)

Comment 5

9 years ago
"about:crashes" and crash repont seems to not work with the package I've installed from repository, but work with the tar.gz

This is the crash id
4cea72cc-4e13-4a13-bf9d-a8b202090701

Comment 6

9 years ago
Linked: http://crash-stats.mozilla.com/report/index/4cea72cc-4e13-4a13-bf9d-a8b202090701
Keywords: crashreportid
Summary: Crash when scrolling down the page → Crash when scrolling down the page [@ libqtcurve.so@0x2f4e1 ]
Whiteboard: crashidneeded

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

9 years ago
Signature	libqtcurve.so@0x2f4e1
UUID	4cea72cc-4e13-4a13-bf9d-a8b202090701
Time 	2009-07-01 06:41:02.364889
Uptime	25
Last Crash	39 seconds before submission
Product	Firefox
Version	3.5
Build ID	20090624012820
Branch	1.9.1
OS	Linux
OS Version	0.0.0 Linux 2.6.27.23-0.1-pae #1 SMP 2009-05-26 17:02:05 -0400 i686 GNU/Linux
CPU	x86
CPU Info	GenuineIntel family 10 model 23 stepping 6
Crash Reason	SIGSEGV
Crash Address	0xb52594e1
User Comments	Crash when scroll down
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libqtcurve.so 	libqtcurve.so@0x2f4e1 	
1 	libqtcurve.so 	libqtcurve.so@0x22146 	
2 	libqtcurve.so 	libqtcurve.so@0x26e00 	
3 	libgtk-x11-2.0.so.0.1400.4 	libgtk-x11-2.0.so.0.1400.4@0x1a401d 	
4 	libxul.so 	moz_gtk_widget_paint 	widget/src/gtk2/gtk2drawing.c:1164
5 	libxul.so 	ThemeRenderer::NativeDraw 	widget/src/gtk2/nsNativeThemeGTK.cpp:648
6 	libxul.so 	NativeRendering 	gfx/thebes/src/gfxGdkNativeRenderer.cpp:67
7 	libxul.so 	cairo_draw_with_gdk 	gfx/thebes/src/cairo-xlib-utils.c:309
8 	libxul.so 	gfxGdkNativeRenderer::Draw 	gfx/thebes/src/gfxGdkNativeRenderer.cpp:110
9 	libxul.so 	nsNativeThemeGTK::DrawWidgetBackground 	widget/src/gtk2/nsNativeThemeGTK.cpp:784

Reporter: in short, your libqtcurve library which is probably a theme engine from your distro is buggy. Please send a bug report (e.g. the url to bug 501655 comment 7) to your distro and ask them to investigate it. Your distro may have instructions for installing debugging symbols for its applications, in which case you'd probably want to install symbols for firefox/libqtcurve/gtk and then crash again using your system's firefox and report the stack from that firefox to your distro (SuSE ?).
Component: General → Widget: Gtk
Keywords: crashreportid
Product: Firefox → Core
QA Contact: general → gtk
Summary: Crash when scrolling down the page [@ libqtcurve.so@0x2f4e1 ] → Crash when scrolling down the page [@ libqtcurve.so@0x2f4e1 - moz_gtk_widget_paint - ThemeRenderer::NativeDraw]
Version: 3.5 Branch → 1.9.1 Branch
(Assignee)

Updated

7 years ago
Crash Signature: [@ libqtcurve.so@0x2f4e1 - moz_gtk_widget_paint - ThemeRenderer::NativeDraw]

Comment 8

2 years ago
Invalid per comment 7.
But please update the bug if you have more informatoin.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.