Fennec crashes loading some sites in third or fourth tab on N810

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Neeti Jain, Unassigned)

Tracking

(Depends on: 1 bug)

Dependency tree / graph

Details

(Whiteboard: [fennectestday])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; GTB6; .NET CLR 1.1.4322; InfoPath.2; .NET CLR 2.0.50727)
Build Identifier: 

Fennec crashes loading some sites in third or fourth tab on N810

Load http://www.cnn.com/
Open new tab and load http://www.yahoo.com/
Open new tab and load http://www.youtube.com/
Fennec crashes while loading http://www.youtube.com/

I also tried loading http://www.cnn.com/, http://en.wikipedia.org/, http://www.ebay.com/ and http://www.google.com/
Fennec crashes while loading google in the fourth tab

I also tried loading http://www.yahoo.com/, http://www.foxnews.com/, http://www.bloomberg.com/ and http://www.google.com/
Fennec crashes while loading google in the fourth tab or bloomberg in the third tab


Reproducible: Always

Actual Results:  
Load http://www.cnn.com/
Open new tab and load http://www.yahoo.com/
Open new tab and load http://www.youtube.com/




Expected Results:  
Fennec crashes while loading http://www.youtube.com/
(Reporter)

Comment 1

9 years ago
Expected Results:
Fennec should load http://www.youtube.com/ succesfully
(Reporter)

Updated

9 years ago
Whiteboard: [fennectestday]
is this an issue with running out of memory?  Marking as a blocker for beta 3
tracking-fennec: --- → 1.0b3+
Can we get this confirmed by someone with an n810?
I can confirm this with the steps to reproduce. There are times when I can't even get to the 4th tab.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have opened six tabs a few times. This is, IMO, a memory error.
I agree this points to a memory error, but this was tested on a desktop
Depends on: 513091
This is fixed due to the patch from bug 503784. I'm not seeing a crash on
panning with build:

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2a2pre) Gecko/20090901
Fennec/1.0b4pre
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Depends on: 503784

Updated

8 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
QA Contact: maemo-linux → general
Hardware: x86 → ARM
You need to log in before you can comment on or make changes to this bug.