Closed Bug 501714 Opened 11 years ago Closed 10 years ago

Last tab should show close button when browser.tabs.closeWindowWithLastTab=false (missing close button, no close button on last tab, does not have)

Categories

(Firefox :: Tabbed Browser, defect, minor)

3.5 Branch
defect
Not set
minor

Tracking

()

RESOLVED FIXED
Firefox 3.7a4

People

(Reporter: TuringT, Assigned: dao)

References

Details

(Keywords: common-issue+, ue)

Attachments

(1 file, 3 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

When closing tabs with the keyboard (Ctrl+W) and preference closeWindowWithLastTab=false, the last Ctrl+W clears the content in the last tab and shows a blank page. 

But in Firefox 3.5 the close button has been removed from the last open tab, so it's impossible to clear its contents with the mouse. This is inconsistent behavior between keyboard and mouse.


Reproducible: Always

Steps to Reproduce:
1. Open about:config
2. Set preference browser.tabs.closeWindowWithLastTab=false
3. Close all tabs on the window with the close button in each tab.
Actual Results:  
The last tab doesn't show a close button.

Expected Results:  
The last tab should show the close button, pressing it should show a blank page as per the browser.tabs.closeWindowWithLastTab=false preference.

Note that this is NOT a duplicate of Bug 456425. That bug was about the default behavior when the closing the last tab closes the window, and used the option to set closeWindowWithLastTab=false as a rationale for the Wontfix. This current bug is present even when using the solution provided by bug 456425
Version: unspecified → 3.5 Branch
I confirm that the 'x' is missing from the last tab. (Linux, Final RC)
Is it a bug or not? Its absence is the subject of this thread on mozilla.support.firefox:
http://tinyurl.com/lt648q
There's a workround on that thread too.
it seems that many people don't like this change, including me.
anything can do for this matter?
Blocks: 490166
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch patch (obsolete) — Splinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #388458 - Flags: review?(gavin.sharp)
Not allowing close for the last tab prevents current (habitual) behavior of closing a banking or other non-work (eg. social network) sites; and since these can be returned to (accidentally) when using 'back' (or back-history) this is very annoying.  I have already started to train myself to open a blank-tab, so as to close the other tab, as a work around.

Was this an intended feature, and still up for debate (or vote)?
Changed summary to improve retrievability.

I'll be another user looking forward to this patch landing.
Not having a close button on the last tab (especially when closeWindowWithLastTab=false) feels very wrong for the very common usage scenario that you want to clear up all tabs and start afresh in the same browsing window. For the same reason, IMO the default settings should be changed to closeWindowWithLastTab=false so that we get to see the close button on last tab by default.
Summary: Last tab should show close button when browser.tabs.closeWindowWithLastTab=false → Last tab should show close button when browser.tabs.closeWindowWithLastTab=false (missing close button, no close button on last tab, does not have)
Not sure if this is a reflection of the same bug, or another aberrant behavior...

However, I have tabs which decline to close [tab won't disappear when clicking the red-x, or the drop down list]

The tabs exhibiting this behavior [with multiple tabs open] can still be used to populate with another URL.

Fox 3.5.1, with tab mix plus.   This appears as a new habit after the install of 3.5.1 update from 3.5
Confirmed that this same behavior occurs with TaxMixPlus disabled.

Tab to far left remains, even with other tabs open, and that tab retains a RedX and will not close, either by the red button, or the drop down request to close the tab.

When the next tab to the right is a blank, closing it results in behavior which implies that that tab thinks it is the only one, and keeps returning as the blank tab.
See Bug 501549 ?
Really common user complaint.
Keywords: common-issue+
My current workaround is:
browser.tabs.closeWindowWithLastTab := false and use Ctrl-F4 or Ctrl-W

I have tried 
browser.tabs.closeButtons := 3
But I don't like that retro style.

This bug is annoying.
Attached patch patch (obsolete) — Splinter Review
updated to trunk
Attachment #388458 - Attachment is obsolete: true
Attachment #394684 - Flags: review?(gavin.sharp)
Attachment #388458 - Flags: review?(gavin.sharp)
(In reply to comment #9)
> Really common user complaint.

I can see "no more close button on the last tab" being a common complaint, but this bug is only about addressing that behavior when a hidden pref is changed, so I doubt the fix will be of interest to most people who are complaining (unless they're also content to just use the preference).
I also would prefer having a close button on the last tab.
(Currently I am forcing FF to do so via userchrome.css)
I confirm this behaviour in 3.5.2 and it is EXTREMELY annoying.  The change in the closeWindowWithLastTab preference to a default of True is very illogical.  How many other programs shut down entirely when an object internal to the program is closed??  Close the last document in a word processor and the whole program dies?  No.  Why then my browser?  Thankfully I found the preference and changed it, so that annoyance is gone.  But why make the last tab behave differently from all the others?  Please put the red X back!  Thank you.
Keywords: ue
the context menu item "close tab" is also greyed out in this case, however middle-click to close still works.

to sum up:

one can "close" with:
ctrl-W, ctrl-F4
middle-click

cannot "close" with:
close button
context menu
Duplicate of this bug: 514229
if firefox 3.7 will have the rigid home-tab on the left this issue would become invalid anyway.
Duplicate of this bug: 511577
Duplicate of this bug: 501549
Attached patch patch (obsolete) — Splinter Review
updated to tip
Attachment #394684 - Attachment is obsolete: true
Attachment #433787 - Flags: review?(gavin.sharp)
Attachment #394684 - Flags: review?(gavin.sharp)
Attached patch patchSplinter Review
updated to tip
Attachment #433787 - Attachment is obsolete: true
Attachment #433922 - Flags: review?(gavin.sharp)
Attachment #433787 - Flags: review?(gavin.sharp)
Attachment #433922 - Flags: review?(gavin.sharp) → review+
http://hg.mozilla.org/mozilla-central/rev/dc3fc62bb552
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a4
filed Bug 554300 for the "close tab" context menu item
Blocks: 554300
Duplicate of this bug: 490166
I'd like this too...to at least have the OPTION for an x on that last tab, like what used to be there.
Duplicate of this bug: 600836
You need to log in before you can comment on or make changes to this bug.