View Source - Does not work

RESOLVED WORKSFORME

Status

()

Firefox
Menus
--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: nhamm, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729) Ubiquity/0.1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729) Ubiquity/0.1.4

Viewing a page source does not work in FF 3.5 neither does Ctrl + U.

Reproducible: Always

Steps to Reproduce:
1. Load any page (say, this one for example)
2. Try View/Page Source or Ctrl U
Actual Results:  
Nothing! :D

Expected Results:  
Should be able to view page source.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1pre) Gecko/20090630 Shiretoko/3.5.1pre

Works fine for me.
Reporter, please start Firefox in safe mode (http://support.mozilla.com/kb/Safe+Mode) and try again. Can you please check the error console under tools too? Are there any errors listed?
(Reporter)

Comment 3

9 years ago
Restarted in Safe-Mode.  Still does not work.

Opened error console (in safe mode).

Ctrl + U yields: Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch2.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://global/content/viewSourceUtils.js :: anonymous :: line 22"  data: no]

View/Page Source yields: Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch2.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://global/content/viewSourceUtils.js :: anonymous :: line 22"  data: no]
nhamm, thanks for your reply. Lets do one remaining step to make sure nothing is broken in your profile. Please create a new one for testing purposes. You can delete the new one afterward. Just do the same steps in a fresh profile.

http://support.mozilla.com/en-US/kb/Managing+profiles
(Reporter)

Comment 5

9 years ago
made new user profile.

Ctrl + U
Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch2.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://global/content/viewSourceUtils.js :: anonymous :: line 22"  data: no]

View/Page Source
Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch2.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://global/content/viewSourceUtils.js :: anonymous :: line 22"  data: no]
nhamm, it looks like your Firefox installation is broken. Can you please click on the link which is next to the error? Copy&paste 5-8 lines around the line where the exception happens. Thanks.

Updated

9 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Comment 7

9 years ago
Fixed in the latest release of FireFox.  Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.