"Save Image As..." downloads the image again

RESOLVED DUPLICATE of bug 120809

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 120809
9 years ago
9 years ago

People

(Reporter: Slava Durdaliev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; ru; rv:1.9.0.11) Gecko/2009061118 Fedora/3.0.11-1.fc10 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; ru; rv:1.9.0.11) Gecko/2009061118 Fedora/3.0.11-1.fc10 Firefox/3.0.11

When I "Save image as...", FF starts downloading it over again instead of copying the picture file from the local cache.

Reproducible: Always

Steps to Reproduce:
1. Open a large (or tiny) wallpaper in the browser window, for example: http://omploader.org/vMXdvbQ/Smoke_or_Water_-3264x2448.jpg
Or load a page with a picture.
2. Right-click it when it finishes loading and choose "Save image as..."
Actual Results:  
FF starts loading the image again (and puts it in the download queue).

Expected Results:  
The image is copied to destination locally (from local cache).
(Reporter)

Comment 1

9 years ago
The same behavior can be observed on 3.0.10, 3.0.11 and 3.5.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 120809
You need to log in before you can comment on or make changes to this bug.